质因数分解2(升级版)C++答案

/*【入门】质因数分解2(自制题目)
题目描述:
输入一个正整数n,将n分解成质因数乘积的形式。质因子从小到大排列。
输入格式:
一个整数n。
输出格式:
分解质因数的结果,注意运算符前后应有空格。
样例输入:36
样例输出:36 = 2 * 2 * 3 * 3
*/
/*代码:*/
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <string_view>
#include <malloc.h>
using namespace std;
bool is_p(long long x) {
	if (x <= 1) return false;
	if (x == 2) return true;
	for(int i = 2; i * i <= x; i++) {
		if (x % i == 0) {
			return false;
		}
	}
	return true;
}
int main() {
	int n;
	cin >> n;
	cout << n << ' ' << '=' << ' ';
	while (true) {
		for(int i = 2; i * i <= n; i++) {
			while(n % i == 0 && is_p (i)){
			    n /= i;
			    if (n != 1){
					cout << i << " * ";
				} else {
			    	cout << i;
			        return 0;
			    }
			}
		}
		cout << n;
		break;	
	}	
	return 0;
}

  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值