poj3252stars

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33920 Accepted: 14788

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题意:利用某颗星星左下角及其正下方的星星的个数来判断该星星是属于第几层,比如上图的5属于第三层,3属于第二层,2和4属于第一层,1属于第零层,输出结果就是输出0~n-1层每层有几颗星星

典型的树状数组的题目,这个代码可以看作是一个模板套用

/*
树状数组:c[n] = a[n - 2^k + 1] + a[n]
k是结点n的二进制的结尾的0的个数
*/
#include <iostream>
#include <cstdio>
#define MAX 33000

using namespace std;

int c[MAX], level[MAX];
//求2^k
int lowbit(int x)
{
    return x & (-x);//总觉得这儿是很神奇的,记住吧
}
//求前n项和
int sum(int x)
{
    int sum = 0;
    while(x > 0)
    {
        sum += c[x];
        x -= lowbit(x);//往下定位结点
    }
    return sum;
}
//增加某个元素的值
void add(int x)
{
    while(x < MAX)
    {
        c[x]++;
        x += lowbit(x);//往上找父节点
    }
}
int main()
{
    int n, x, y, i;
    scanf("%d", &n);
    for(i = 0; i < n; i++)
    {
        scanf("%d%d", &x, &y);
        x++;//这儿为啥会加1我还没弄明白,但是我知道不加1是不行的,哈哈
        level[sum(x)]++;//这个就是记录每层有几颗星星了
        add(x);//这个是改变树状数组的值,逐一往上改变
    }
    for(i = 0; i < n; i++)
    {
        printf("%d\n", level[i]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值