hdu1084 What Is Your Grade? 结构体的应用

隔了有两个星期又做了一遍。wa了好几次,所幸ac了,这道题思路好懂,就是写代码的时候,有一些东西写迷!!!

要努力了,好多东西都要学!!

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8215    Accepted Submission(s): 2513


Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!
 

Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 

Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 

Sample Input
  
  
4 5 06:30:17 4 07:31:27 4 08:12:12 4 05:23:13 1 5 06:30:17 -1
 

Sample Output
  
  
100 90 90 95
#include<stdio.h>
#include<algorithm>
using std::sort;
typedef struct {

int time, ques, grade, sor, pre;//time是存时间,ques是存答对的问题的个数,grade是最后成绩,sor是在答对同样的题数中按时间从大到小的序号,pre是输入时的序号; 
}str;
int cmp( str a, str b )
{
	if( a.ques > b.ques ) return true;//按照答题数目从大到小 
	if( a.ques == b.ques && a.time <b.time ) return true;//按照时间从小到大; 
	return false; 
}
int cmp2( str a, str b )
{
	if( a.pre < b.pre ) return true;
	return false;
} 
int main()
{
    str stu[101], stucpy[101];
    int n, i, j, h, f, m, s1, s2, s3, s4;
    while( scanf( "%d", &n ), n >= 0 )
    {
        s1 = s2 = s3 = s4 = 0;//s1是答对一道的统计,s2。。。
        int flag = 1;
        for( i = 0; i < n; i ++ )
        {
            scanf( "%d %d:%d:%d", &stu[i].ques, &h, &f, &m );
            stu[i].time = h*3600+f*60+m;
            if( stu[i].ques == 1 ) ++s1;
            if( stu[i].ques == 2 ) ++s2;
            if( stu[i].ques == 3 ) ++s3;
            if( stu[i].ques == 4 ) ++s4;
            stu[i].pre = flag++;
        }
        //printf( "%d %d %d %d",s1, s2, s3, s4 );
        sort( stu, stu+n, cmp );
        stu[0].sor = 0;
        for( i = 1; i < n-1; i ++ )
        {
        	if(stu[i].ques == stu[i-1].ques )
        	stu[i].sor = stu[i-1].sor+1;
        	else stu[i].sor = 0;
        }
        for( i = 0; i < n; i ++ )
        {
        	switch(stu[i].ques)
			{
        case 1: if( stu[i].sor < s1/2 ) stu[i].grade = 65;
			else stu[i].grade = 60;break;
		case 2: if( stu[i].sor < s2/2 ) stu[i].grade = 75;
			else stu[i].grade = 70;break;
		case 3:	if( stu[i].sor < s3/2 ) stu[i].grade = 85;
			else stu[i].grade = 80;break;
		case 4:if( stu[i].sor < s4/2 )	stu[i].grade = 95;
			else stu[i].grade = 90; break;
		case 5:	stu[i].grade = 100;break;
		default : stu[i].grade = 50;
		}
		}
		//printf( "....");//不一定是按照答题的数目的大小来输入输出的 所以这种方法是错的 
		/*flag = 1;
		for( flag = 1; flag <= 5; flag ++ )
		for( i = 0; i < n; i ++ )
		if( stu[i].pre == flag )
		{
			printf( "%d\n", stu[i].grade );
			break;
		}*/
		sort( stu, stu+n, cmp2 ); 
		for( i = 0; i < n; i ++ )
		printf( "%d\n", stu[i].grade );
                printf( "\n" );
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值