hdu 1007 Quoit Design 找最近的两个点的距离

几何数学类的问题 刚开始用的O(n^2)双重循环 TL了,这道题在《算法导论》33章有解释

/*
Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.

 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.

 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 

 

Sample Input
2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0
 

Sample Output
0.71
0.00
0.75
*/
//这是找最近的点的问题
#include<stdio.h>
#include<math.h>
#include<algorithm> 
using std::sort;
struct str{
	double x, y;
}s[100002];
int p[100002]; //储存距离中间线不大于ans的序号; 
double cmpx( str a, str b )//对x排序 从小到大 
{
	return a.x < b.x;
} 
double cmpy( int a, int b )//a【p】数组的y排序 从小到大 
{
	return s[a].y < s[b].y;
}
double min( double a, double b ) 
{
	return a>b?b:a;
}
double dis( str a, str b )//两个点的距离 
{
	return sqrt( (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y) );
}
double find(int l,int r)
{
     if( l+1==r ) return dis( s[l], s[r] );//临界条件1 
	 if( l+2==r )//临界条件2 
	 return min( dis( s[l], s[r]), min( dis(s[l+1], s[r]), dis(s[l], s[l+1])));
	 int mid = (l+r)/2;
	  int cnt = 0, i, j;
	  double ans = min( find(l, mid), find(mid+1, r) );//找到中间线两边的最距离 
	  for( i = l; i <= r; i ++ )
	  if( s[i].x>=s[mid].x-ans&&s[i].x<=s[mid].x+ans )
	  p[cnt++] = i;//记录距离中间线不大于ans的序号
	  sort( p, p+cnt, cmpy );
	  for( i = 0; i < cnt; i ++ )
	  {
	  	for( j =i+1; j < cnt; j ++ )
	  	{
	  		if( s[p[j]].y-s[p[i]].y>=ans ) break;//判断两个坐标的纵距离,如果不小于ans这一对肯定不是要找的最小的距离对 
	  		ans = min( ans, dis( s[p[i]], s[p[j]] ));
	  	}
	  }
	  return ans;
}
int main()
{
	int n; 
	while( ~scanf( "%d", &n ) )
	{
		if( n== 0 ) break;
		for( int i = 0; i < n; i ++ )
		scanf( "%lf%lf", &s[i].x, &s[i].y );
		sort( s, s+n, cmpx );//预排序 
		printf( "%.2lf\n", find(0, n-1)/2 );
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值