hdoj1047

吃了好几个wa;分析一下原因:

首先该题的输入有错误,不是

1

 

99999999999999999

999999999999999999

0

而是

1

99999999999999999

999999999999999

0

同时杭电对格式要求特别严;

以上是客观因素;

主观因素:

题目考虑不周到,没有将每一位都弄成0~9之间;然后对究竟是以数组的第一位为最高位还是为最低位纠结了好半天;想来想去还是以第一位为最低位最好,以后都要以第一位为最高位;

代码如下:

 

/*Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

 

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

 

Output
Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

Sample Input
1


123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
 

Sample Output
370370367037037036703703703670
*/
/*
特殊数据:
一:1
9999
99
0

out
10098;
er:1
00
00
0

out
0;
*/
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
    int n, i, sum[105];
    char str[105];
   scanf( "%d", &n );
    while(  n-- )
    {
           
           memset( sum, 0, sizeof(sum) );
           while( scanf( "%s", str ) )
           {
                  if( strcmp( str, "0" ) == 0  ) break;
                 int len = strlen(str);
                for( i = len-1; i >= 0; i --)//将sum[0]定义为最低位
                {
                sum[len-i-1] += str[i]-'0';
                if( sum[len-i-1] >9 )
                {
                    sum[len-i-1]-=10;
                    ++sum[len-i];
                    }
                    }
           }
           for( i = 0; i < 104; i ++ )//将每一位都确定为0~9之间
           if( sum[i] > 9 )
           {
               sum[i]-=10;
               ++sum[i+1];
               }
          
           for( i = 104; i > 0; i -- )
           if( sum[i] ) break;
           for( int k = i; k >= 0; k -- ){
           printf( "%d", sum[k]);
           }
           printf( "\n" );
           if( n )
           printf( "\n" );
           }
           system( "pause" );
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值