NYoj 1112 求次数 【水】

求次数

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述

题意很简单,给一个数n 以及一个字符串str,区间【i,i+n-1】 为一个新的字符串,i 属于【0,strlen(str)】如果新的字符串出现过ans++,例如:acmacm n=3,那么 子串为acm cma mac acm ,只有acm出现过

求ans;

输入
LINE 1: T组数据(T<10)
LINE 2: n ,n <= 10,且小于strlen(str);
LINE 3:str
str 仅包含英文小写字母 ,切长度小于10w
输出
求 ans
样例输入
2
2
aaaaaaa
3
acmacm
样例输出
5
1

就是将所有的都存起来,排个序,遍历

代码:

 
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
const int M = 200000;
using namespace std;

struct node{
	char str[12];
}s[M];
char str[M];

bool cmp(node a, node b){
	if( strcmp(a.str, b.str) <= 0 ) return 1;
	return 0;
}

int main(){
	int t, n;
	scanf("%d", &t);
	while(t --){
		scanf("%d%s", &n, str);
		int len = strlen(str);
	//	memset(s, 0, sizeof(s));
		for(int i = 0; i <= len-n; ++ i){
			for(int j = 0; j < n; ++ j)
				s[i].str[j] = str[j+i];
			s[i].str[n] = '\0';
		}
		sort(s, s+len-n+1, cmp);
		int ans = 0;
		for(int i = 1; i <= len-n; ++ i){
			if(strcmp(s[i].str, s[i-1].str) == 0) ++ans;
		}
		printf("%d\n", ans);
	}
	return 0;
}        


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值