poj 1611 The Suspects 【并查集】

The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 24570 Accepted: 12033

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source

Asia Kaohsiung 2003

题意:SARS会互相传播,我们假定0是感染体,凡是0待过的组,组内成员都会感染,问感染的人数。
这道题的所用的并查集并不是常写的并查集,而是按序合并的并查集。
我们用一个数组num[i],表示以i为祖先的节点所感染的总数目,我们只需要找出0的祖先节点即可。
代码:

#include <cstdio>
#include <cstring>
#include <iostream>
const int M = 3e4+5;
using namespace std;

int num[M], fat[M], ra[M];

void init(int n){
    for(int i = 0; i <= n; ++ i) {
        ra[i] = 0; num[i] = 1; fat[i] = i;
    }
}

int f(int x){
    int r = x;
    while(x != fat[x]) x = fat[x];
    while(r != x){
        int temp = fat[r];
        fat[r] = x;
        r = temp;
    }
    return r;
}

void un(int x, int y){
    x = f(x); y = f(y);
    if(x == y) return ;
    if(ra[x] > ra[y]){
        fat[y] = x;
        num[x] += num[y];
    }
    else{
        fat[x] = y;
        if(ra[x] == ra[y]) ++ ra[y];
        num[y] += num[x];
    }
}

int main(){
    int n, m;
    while(scanf("%d%d", &n, &m), n||m){
        int a, b, c;
        init(n);
        for(int i = 0; i < m; ++ i){
            scanf("%d%d", &a, &b);
            for(int j = 1; j < a; ++j){
                scanf("%d", &c);
                un(b, c);
                b = c;
            }
        }
        a = f(0);
        printf("%d\n", num[a]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值