Poj 3087 Shuffle'm Up 【BFS】

Shuffle’m Up

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6556 Accepted: 3077

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input
2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC
Sample Output
1 2
2 -1

Source

Greater New York 2006
题意:给你两个字符串长度为n的字符串a, b,先将b【0】放在最下面,再将a[0]放到b[0]上面,再放b[1],a[1]。。。最后合成一个想的长度为2n的字符串,之后再将新的字符串的前一半变成一个新的a,后一半变成b,继续先将b【0】放在最下面,再将a[0]放到b[0]上面,再放b[1],a[1]。。。
在此期间会有多种不同的组成方式,问能不能组合成给出的字符串。
分析:一看就是BFS,用set来记录。
代码:

#include <iostream>
#include <string>
#include <cstring>
#include <set>
#include <queue>
using namespace std;

struct node{
    string a, b;
    int step;
    bool operator < (const node &q) const {
        return step > q.step;
    }
};
string e;

int bfs(node st, int n){
    set<string> vis;
    priority_queue<node >q;
    q.push(st);
    while(!q.empty()){
        node temp = q.top(); q.pop();
        string cur;
        for(int i = 0; i < n; ++ i){
            cur += temp.b[i];
            cur += temp.a[i];
        }
        if(cur == e) return temp.step+1;
        else if(vis.find(cur) == vis.end()){
            vis.insert(cur);
            node te;
            te.a.assign(cur, 0, n);
            te.b.assign(cur, n, 2*n);
            /*string qq(cur.begin(), cur.begin()+n);
            te.a.assign(te.a.begin(), cur.begin(), cur.begin()+n);
            te.a.assign(te.b.begin(), cur.begin()+n, cur.end());*/
            te.step = temp.step+1;
            q.push(te);
        }
    }
    return -1;
}

int main(){
    //ios::sync_with_stdio(false);/据说可以加快读输速度。
    int t;
    cin >>t;
    for(int i = 1; i <= t; ++ i){
        int n;
        cin >> n;
        node st;
        cin >>st.a >>st.b >> e;
        st.step = 0;
        int ans = bfs(st, n);
        cout << i <<" "<< ans <<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值