1073成绩排名

样例输入

2
5
B05021924 90
B07030901 91
B07030419 90
B07021027 93
B06060606 87
1
D0408 100

样例输出

Case 1:
1 B07021027 93
2 B07030901 91
3 B05021924 90
3 B07030419 90
5 B06060606 87
Case 2:
1 D0408 100



#include<iostream>
using namespace std;
struct node
{
    char name[11];
    int num;
    struct node *next;
};
int main()
{
    //freopen("a.txt","r",stdin);
    struct node str[101];
    struct node *pt,*p;
    char a[11];
    int b;
    int N,n,i,j,k;
    scanf("%d",&N);
    for(k=1;k<=N;k++)
    {
        for(i=0;i<=100;i++)
        {
            str[i].num=0;
            str[i].next=NULL;
        }
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%s%d",&a,&b);
            pt=&str[b];
            for(j=0;j<str[b].num;j++)
            {
                pt=pt->next;
            }
            p=new struct node;
            strcpy(p->name,a);
            p->next=NULL;
            str[b].num++;
            pt->next=p;
        }
        cout<<"Case "<<k<<":"<<endl;
        for(i=100,j=1;i>=0;i--)
        {
            if(str[i].num!=0)
            {
                pt=str[i].next;
                while(pt!=NULL)
                {
                    cout<<j<<' ';
                    cout<<pt->name<<' '<<i<<endl;
                    pt=pt->next;
                }
                j+=str[i].num;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值