03-树2 List Leaves (25分)

03-树2 List Leaves (25分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:
4 1 5

Solution: 题目的意思很明显给定一个树输出它的叶子节点(从上到下,从左到右输出)。其中给定的这棵树有N个节点(从0开始编号),对于每一个节点还给出它的左右儿子的索引及左右儿子的位置。因此,我们可以采用顺序存储结构来存储这颗二叉树,因为树是以顺序索引的格式给定的,因此我们需要确定这个二叉树的根节点,其中根节点最明显的特征就是他不是任何节点的儿子,因此我们需要采用一个标记数组来确定其根节点。其中输出叶子节点可以采用层次遍历的方法进行输出。其中我们使用 null=1 来表示该节点不存在。
注意:对于树的存储表示和层次遍历不了解的可以看这blog
例如:给定的二叉树为:

value01234567
left index1-102-1-154
right index-1-1-17-1-1-16

因此:这颗二叉树为:
二叉树

code

#include<iostream>
#include<vector>
#include<queue>

using namespace std;

using Tree = int ;
#define null -1  //用来表示-

struct TreeNode {
    int data;
    Tree left;
    Tree right;
};

int buildTree(vector<TreeNode> &tree, int N)
{
    Tree root= -1;
    char lef, rig;
    vector<int> check(N, 0);

    for(int i = 0; i < N; ++i)
    {
        cin >> lef >> rig;
        tree[i].data = i;
        if(lef != '-') {
            tree[i].left = (int)(lef - '0');
            check[tree[i].left] = 1;    //标记该节点,及不可能为根节点
        } else
            tree[i].left = null;
        if (rig != '-') {
            tree[i].right = (int)(rig - '0');
            check[tree[i].right] = 1;
        } else
            tree[i].right = null;
    }
    int i = 0;
    for(; i < N; ++i)
        if(!check[i]) {
            root = i;
            break; //如果该节点没有被标记则为根节点
        }
    return root;
}

vector<int> findLeaves(const vector<TreeNode> &tree, Tree root)
{
    vector<int> leaves;
    queue<TreeNode> qu;
    TreeNode node;

    if(root == null)
        return {};
    qu.push(tree[root]);
    while(!qu.empty()) {
        node = qu.front();
        qu.pop();
        //如果该节点左右儿子都不存在则为根节点
        if((node.left == null) &&
           (node.right == null))
            leaves.push_back(node.data);
        if(node.left != null) qu.push(tree[node.left]);
        if(node.right != null) qu.push(tree[node.right]);
    }
    return leaves;
}

int main()
{
    int N;
    //vector<Tree> tree;
    Tree root;

    cin >> N;   //输入节点的个数
    vector<TreeNode> tree(10);
    root = buildTree(tree, N);

    auto res = findLeaves(tree, root);
    for(decltype(res.size())i=0; i != res.size(); ++i)
    {
        cout << res[i];
        //注意:最后一个数字输出后没有空格
        i != res.size() - 1 ? cout <<" " : cout << endl;
    }
    return 0;
}
  • 4
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值