Primary Arithmetic
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 8450 | Accepted: 3166 |
Description
Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty.
Input
Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.
Output
For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.
Sample Input
123 456 555 555 123 594 0 0
Sample Output
No carry operation. 3 carry operations. 1 carry operation.
Source
又是一道英文题。给两个不超过十位的正整数,问它们相加的过程中,一共有几次进位。
高精度模拟,做过高精度加法的同学都不会觉得太难吧。
注意点:
1)当仅有一次进位的时候,输出"operation",其他时候输出"operations".
2)进位时候,当两个数字长度不相同时,考虑多出部分的进位,如:“99999 + 1”。
代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>
char num1[20];
char num2[20];
int main(void){
int add, tmp;
int carry;
int i, j;
int len1, len2;
while (scanf("%s %s", num1, num2), strcmp(num1, "0") != 0 || strcmp(num2, "0") != 0){
getchar();
len1 = strlen(num1);
len2 = strlen(num2);
for (carry = add = 0, i = len1 - 1, j = len2 - 1 ; i >= 0 && j >= 0; i--, j--){
if ((num1[i] - '0') + (num2[j] - '0') + add >= 10){
add = 1;
carry ++;
}
else{
add = 0;
}
}
for (; i >= 0; i--){
if (num1[i] - '0' + add >= 10){
carry++;
add = 1;
}
else {
add = 0;
}
}
for (; j >= 0; j--){
if (num2[j] - '0' + add >= 10){
carry++;
add = 1;
}
else {
add = 0;
}
}
if (carry == 0){
printf("No carry operation.\n");
}
else if (carry == 1){
printf("1 carry operation.\n");
}
else{
printf("%d carry operations.\n", carry);
}
}
return 0;
}