UVA 10382 Watering Grass(浇草)(贪心 + 区间覆盖问题) 

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from the left end of the center line and its radius of operation.

What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?

 

            

Input Input

consists of a number of cases. The first line for each case contains integer numbers n, l and w with n ≤ 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output ‘-1’.

 

Sample Input

8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10

1 3

5 9

3 6

1 3

10 1

5 3

1 1

9 1

Sample Output

6

2

-1

(贪心 + 区间覆盖问题) 

这个题是典型的贪心问题,意思是有大大小小的水管来浇草坪,如果全部覆盖至少用多少水管;

给出水管在草坪的位置和半径。从示意图可以看出一个水管的有效面积为它的左端点和右端点

a[k].x=q-sqrt(r*r-w*w/4.0);

a[k].y=q+sqrt(r*r-w*w/4.0);

排序   因为要求的是最小,平时求的都是最大,排序的时候要注意,同时开始的覆盖面积大的排前面。

这种类型的题和平时的贪心差不多,但是要注意数值的精确值,将多余的都不看,看一个水管实际能覆盖到的面积;

可以从任意一头开始计算, 但排序的时候就要开始不同了。


             

 

          代码如下

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
struct node
{
    double x,y;
} a[100020];
bool cmp(node xx,node yy)
{
    if(xx.x==yy.x)
        return xx.y>yy.y;
    else
        return xx.x<yy.x;
}
int main()
{
    int n;
    double l,w;
    double q,r;
    while(~scanf("%d%lf%lf",&n,&l,&w))
    {
        int k=0;
        for(int i=0; i<n; i++)
        {
            scanf("%lf%lf",&q,&r);
            if(r*2<=w)
                continue;
            a[k].x=q-sqrt(r*r-w*w/4.0);
            a[k].y=q+sqrt(r*r-w*w/4.0);
            k++;
        }
        sort(a,a+k,cmp);
        if(a[0].x>0||k==0)//开头若不覆盖,直接结束
        {
            printf("-1\n");
            continue;
        }
        double x=0,y=a[0].y;
        int sum=1;//第一个加上 
        for(int i=1; i<k; i++)
        {
            if(a[i].x<=x)//找下一个水管的要求是左端点 要小于等于上个水管的右端点 
            {
                if(a[i].y>y)//如果右端点较大,更新水管 
                    y=a[i].y;
                continue;
            }
            if(y>=l)// 喷水总距离达到要求结束
                break;
            if(a[i].y<=y)
                continue;
            if(a[i].x>x) 
            {
                if(a[i].y>y)
                    break;
                x=y;
                y=a[i].y;
                sum++;
            }
        }
        if(y>=l)
            printf("%d\n",sum);
        else
            printf("-1\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值