/*此题算是暴力求解,关键是如何剪枝的问题,此题是连续找出四条边即可,其实这么说有时给出的数据可以
凑出许多种的正方形,这些正方形中一定可调成一支特殊的正方形,就是每条边的组成线段都是递增的,然后
就一条边来说,就可以利用现在寻找的每条组成边的线段都是递增来剪枝,开始先排序一下,调用递归*/
Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
Sample Input
Sample Output
# include "stdio.h"
# include "string.h"
# include <algorithm>
using namespace std;
int n, sum;
int a[30];
int used[30];
void init()
{
for(int i=0; i<=29; i++)
{
used[i]=1;
}
}
int dfs(int _n, int m, int num)
{
if(m==sum)
{
m=0;
_n=0;
num++;
if(num==4)
return 1;
}
for(int i=_n+1; i<=n; i++)
{
if(m+a[i]<=sum&&used[i])
{
used[i]=0;
if(dfs(i, m+a[i], num))
return 1;
used[i]=1;
}
}
return 0;
}
int main()
{
int t, i, j;
scanf("%d", &t);
for(i=1; i<=t; i++)
{
scanf("%d", &n);
sum=0;
for(j=1; j<=n; j++)
{
scanf("%d", &a[j]);
sum=sum+a[j];
}
if(sum%4!=0)
{
printf("no\n");
}
else
{
sort(a+1,a+1+n);
sum=sum/4;
init();
if(dfs(0, 0, 0))
printf("yes\n");
else
{
printf("no\n");
}
}
}
return 0;
}