poj 2362 Square

Square
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 15977 Accepted: 5505

Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes

Source

限制条件还是比较多的,首先和能够被4整出得到side,然后最长的棍子不可以超过sum的1/4 。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
using namespace std;
int n,len[30],side;
bool vis[30],flag;
inline bool cmp(int x,int y)
{
    return x>y;
}
void read()
{
    memset(vis,0,sizeof(vis));
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    scanf("%d",&len[i]);
}
void dfs(int num,int length,int cs)
{
    if(cs==3) //形成三边的时候就形成square了
    {
        flag=1;
        return ;
    }
    if(length==side) dfs(1,0,cs+1);
    if(flag)return ;
    for(int i=num;i<=n;i++)
    {
        if(!vis[i]&&length+len[i]<=side)
        {
            vis[i]=true;
            dfs(i+1,len[i]+length,cs);//尝试一次一次的加边使之达到side
            if(flag) return ;
            vis[i]=false;
        }
    }
}

void solve()
{
    flag=0;
    dfs(1,0,0);
    if(!flag)
    {
        printf("no\n");
        return;
    }
    printf("yes\n");
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        read();
        int sum=0,maxx=0;
        for(int i=1;i<=n;i++)
        {
            sum+=len[i];
            maxx=max(maxx,len[i]);
        }
        if(sum%4!=0||4*maxx>sum)
        printf("no\n");
        else
        {
            sort(len+1,len+n+1,cmp);
            side=sum/4;
            solve();
        }
    }
    return 0;
}

看了下,sort函数里面的形式,还有要定义cmp。。。第一次用这个的说
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值