hdu 1007 Quoit Design

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18291    Accepted Submission(s): 4713


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
 

Sample Input
  
  
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
  
  
0.71 0.00 0.75
 

Author
CHEN, Yue
 

Source
 

Recommend
JGShining
 

最近点对。。
题意:给你N个点,求这N个点中两点距离最近的那个值,直接暴力肯定会TLE,所以思路是分治。
这题模板题,具体思路算法导论上33章第四节591面上有,不解释了。。。
复杂度O(nlgn)

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
const int maxn=100005;
struct Point
{
    double x,y;
    int index;
};
Point a[maxn],b[maxn],c[maxn];
double dis(Point a,Point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int merge(Point p[],Point q[],int s,int m,int t)
{
    int i,j,k;
    for(i=s,j=m+1,k=s;i<=m&&j<=t;)
    {
        if(q[i].y>q[j].y) p[k++]=q[j],j++;
        else  p[k++]=q[i],i++;
    }
    while(i<=m) p[k++]=q[i++];
    while(j<=t) p[k++]=q[j++];
    memcpy(q+s,p+s,(t-s+1)*sizeof(p[0]));
    return 0;
}
double closest(Point a[],Point b[],Point c[],int p,int q)
{
    if(q-p==1) return dis(a[p],a[q]);
    else if(q-p==2)
    {
        double x1=dis(a[p],a[q]);
        double x2=dis(a[p+1],a[q]);
        double x3=dis(a[p],a[p+1]);
        if(x1<x2&&x1<x3) return x1;
        else if(x2<x3) return x2;
        else return x3;
    }
    int i,j,k,m=(p+q)/2;
    double d1,d2;
    for(i=p,j=p,k=m+1;i<=q;i++)
        if(b[i].index<=m)
            c[j++]=b[i];
        else
            c[k++]=b[i];
    d1=closest(a,c,b,p,m);
    d2=closest(a,c,b,m+1,q);
    double dm=min(d1,d2);
    merge(b,c,p,m,q);
    for(i=p;i<k;i++)
    for(j=i+1;j<k&&c[j].y-c[i].y<dm;j++)
    {
        double temp=dis(c[i],c[j]);
        if(temp<dm)
            dm=temp;
    }
    return dm;
}
bool cmp_x(Point a,Point b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
bool cmp_y(Point a,Point b)
{
    if(a.y==b.y)
        return a.x<b.x;
    return a.y<b.y;
}
int main()
{
    int i,n;
    double d;
    while(scanf("%d",&n)!=EOF,n)
    {
        for(int i=0;i<n;i++)
            scanf("%lf%lf",&a[i].x,&a[i].y);
        sort(a,a+n,cmp_x);
        for(int i=0;i<n;i++)
            a[i].index=i;
        memcpy(b,a,n*sizeof(b[0]));
        sort(b,b+n,cmp_y);
        d=closest(a,b,c,0,n-1);
        printf("%.2lf\n",d/2.0);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
城市应急指挥系统是智慧城市建设的重要组成部分,旨在提高城市对突发事件的预防和处置能力。系统背景源于自然灾害和事故灾难频发,如汶川地震和日本大地震等,这些事件造成了巨大的人员伤亡和财产损失。随着城市化进程的加快,应急信息化建设面临信息资源分散、管理标准不统一等问题,需要通过统筹管理和技术创新来解决。 系统的设计思路是通过先进的技术手段,如物联网、射频识别、卫星定位等,构建一个具有强大信息感知和通信能力的网络和平台。这将促进不同部门和层次之间的信息共享、交流和整合,提高城市资源的利用效率,满足城市对各种信息的获取和使用需求。在“十二五”期间,应急信息化工作将依托这些技术,实现动态监控、风险管理、预警以及统一指挥调度。 应急指挥系统的建设目标是实现快速有效的应对各种突发事件,保障人民生命财产安全,减少社会危害和经济损失。系统将包括预测预警、模拟演练、辅助决策、态势分析等功能,以及应急值守、预案管理、GIS应用等基本应用。此外,还包括支撑平台的建设,如接警中心、视频会议、统一通信等基础设施。 系统的实施将涉及到应急网络建设、应急指挥、视频监控、卫星通信等多个方面。通过高度集成的系统,建立统一的信息接收和处理平台,实现多渠道接入和融合指挥调度。此外,还包括应急指挥中心基础平台建设、固定和移动应急指挥通信系统建设,以及应急队伍建设,确保能够迅速响应并有效处置各类突发事件。 项目的意义在于,它不仅是提升灾害监测预报水平和预警能力的重要科技支撑,也是实现预防和减轻重大灾害和事故损失的关键。通过实施城市应急指挥系统,可以加强社会管理和公共服务,构建和谐社会,为打造平安城市提供坚实的基础。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值