[queue] 奶牛喝汽油(学生起的名字) SP348 EXPEDI

SP348 EXPEDI - Expedition

https://www.luogu.org/problemnew/show/SP348

http://poj.org/problem?id=2431

题意翻译

Xavier养的一群奶牛劫持了一个卡车,并向丛林中逃亡。由于奶牛们不会开车,卡车不幸地撞上了丛林中的一块岩石,并撞破了油箱。于是他们每行驶一个单位距离,油箱就漏一单位油。 为了修理这个卡车,奶牛们需要沿着一条长长的公路行驶到最近的一个城镇。在这条路上,在卡车当前位置和城镇之间,有N个加油站,每个加油站有不多于100单位的汽油。 丛林对于人类来说是个危险的地方,更不用说奶牛了。因此,奶牛们想要他们停下加油的次数尽量少。幸运的是,卡车的油箱是如此的大,可以容纳任意多的汽油。卡车现在距离城镇L单位长度,油箱里有P单位的油。 请求出奶牛们最少的加油次数,或者他们根本无法到达城镇,无解请输出-1 题目有多组数据 每组第一行有一个整数N(N <= 10 , 000) 下面N行,每行两个整数,分别代表每个加油站与城镇的距离和本加油站拥有的汽油量。 每组最后一行有两个整数,LP(1 <= P <= 1 , 000 , 000) 如果奶牛们能到达城镇,输出一个整数,代表最少加油的次数。否则输出-1

题目描述

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

输入输出格式

输入格式:
 

The first line of the input contains an integer t representing the number of test cases. Then t test cases follow. Each test case has the follwing form:

  • Line 1: A single integer, N
  • Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.
  • Line N+2: Two space-separated integers, L and P

输出格式:

For each test case, output a single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

输入输出样例

             1          2            3              4    

P(10)   4(4)     5(2)      11(5)     15(10)      25 

输入样例#1 复制

1   共几组测试数据

4    N

4 4   第一个是距出发点的距离  第二个是可加油量

5 2

11 5

15 10

25 10   L最远距离   P刚开始有的油

输出样例#1 复制

2

 

Input details

The truck is 25 units away from the town; the truck has 10 units

of fuel.  Along the road, there are 4 fuel stops at distances 4,

5, 11, and 15 from the town (so these are initially at distances

21, 20, 14, and 10 from the truck).  These fuel stops can supply

up to 4, 2, 5, and 10 units of fuel, respectively.

 

Output details:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more

units, stop to acquire 5 more units of fuel, then drive to the town.

#include<iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;
#define MAX_N 10000
int group,N,L,P;
struct node{
	int A,B;
}p[MAX_N+5];
bool cmp(node i,node j){
	return i.A<j.A;
}
void print(int a){//测试用 ,不用看 
	int ans=0;
	for(int i=0;i<a;i++){
		cout<<i<<"---"<<p[i].A<<" "<<p[i].B<<"---"<<8965-p[i].A<<endl;
		ans+=p[i].B;
	}
}
int main() {
	freopen("exp.12.in","r",stdin);
	priority_queue<int> pque;
//处理读入的数据 
	cin>>N;
	for(int i=1; i<=N; i++) {
		scanf("%d %d",&p[i].A,&p[i].B);
	}
	cin>>L>>P;
	for(int i=1; i<=N; i++) {
		p[i].A=L-p[i].A;
	}
	sort(p+1,p+N+1,cmp);
//走一站,带走一站的油,发现油箱是负的,停下开始喝油 ,直到油箱不为0 
	p[N+1].A=L;	p[N+1].B=0;	//相当于是加一个油量是0的站
    p[0].A=0;p[N+1].B=0;
	long long trank=P; int ans=0;
	for(int i=1;i<=N+1;i++){
		trank=trank-(p[i].A-p[i-1].A);
		while(trank<0&&!pque.empty()){
			trank+=pque.top();
			pque.pop();
			ans++;
		}
		if(trank<0){
			cout<<-1<<endl; return 0;
		}
		pque.push(p[i].B);
	}
	cout<<ans<<endl;
	return 0;
}
//能不能最小堆 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值