南阳oj 题目217 a letter and a number

a letter and a number

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 1
描述
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
输入
On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出
for each case, you should the result of y+f(x) on a line
样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3
样例输出
19
18
10
-17
-14
-4

注:此题为:南阳oj 题目217 a letter and a number

说明:用scanf读入时,注意回车键也是字符,要加    getchar();  吸收回车;

已AC源代码:

#include<stdio.h>
char ch1[]="0ABCDEFGHIJKLMNOPQRSTUVWXYZ";
char ch2[]="0abcdefghijklmnopqrstuvwxyz";
int yjj(char ch)
{
	int i,x;
	for(i=1;i<=26;++i)
	{
		if(ch==ch1[i])
		{
			x=i;    break;
		}
		if(ch==ch2[i])
		{
			x=(-1)*i;    break;
		}
	}
	return x;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		getchar();
		char c;
		int y,x,sum;
		scanf("%c %d",&c,&y);
		x=yjj(c);
		sum=x+y;
		printf("%d\n",sum);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值