POJ 1936:全在其中(All in All )

All in All

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 2
Problem Description
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
 

Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
 

Output
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
 

Sample Input
  
  
sequence subsequence person compression VERDI vivaVittorioEmanueleReDiItalia caseDoesMatter CaseDoesMatter
 

Sample Output
  
  
Yes No Yes No

中文版:
描述

你设计了一个新的加密技术,可以用一种聪明的方式在一个字符串的字符间插入随机的字符串从而对信息进行编码。由于专利问题,我们将不会详细讨论如何在原有信息中产生和插入字符串。不过,为了验证你的方法,有必要写一个程序来验证原来的信息是否全在最后的字符串之中。

给定两个字符串s和t,你需要判断s是否是t的“子列”。也就是说,如果你去掉t中的某些字符,剩下字符将连接而成为s。

输入
输入包括多个测试样例。每一个都是由空格分隔的由字母数字ASCII字符组成的两个特定的字符串s和t。s和t的长度不超过100000。
输出
对于每个测试样例,如果s是t的“子列”,则输出”Yes”,否则输出”No”
Sample Input
    
    
sequence subsequence person compression VERDI vivaVittorioEmanueleReDiItalia caseDoesMatter CaseDoesMatter
 

Sample Output
    
    
Yes No Yes No


注:此题为:POJ 1936:全在其中

说明:在母串中一直循环,字串的循环,判断时,母串从前往后,不回头,保证顺序

已AC源代码:

#include<stdio.h>
#include<string.h>
#define M 100000
int main()
{
	char ch1[M+1],ch2[M+1];
	while(~scanf("%s %s",ch1,ch2))
	{
		int len1,len2,i,j,k;
		len1=strlen(ch1);
		len2=strlen(ch2);
		k=j=0;
		for(i=0;i<len1;++i)
		{
			if(j==len2)
				break;
			for(;j<len2;j++) //j一直加,从而使顺序不变 
			{
				if(ch1[i]==ch2[j])
				{
					k++;
					j++;
					break;
				}
			}
		}
		if(k==len1)
			printf("Yes\n");
		else
			printf("No\n");
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值