POJ 1258 Agri-Net 最小生成树 prim && kruskal

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 45228 Accepted: 18575

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
注-此题为: POJ 1258 Agri-Net 

题意:
      有n个农场,已知这n个农场都互相相通,有一定的距离,现在每个农场需要装光纤,
问:
怎么安装光纤能将所有农场都连通起来,并且要使光纤距离最小,输出安装光纤的总距离
思路:
       最小生成树,一个二维矩阵代表他们的距离,直接用 prim  。 

已AC代码:(prim

#include<cstdio>
#include<cstring>
#define INF 0xfffffff

int map[125][125],vis[125];//map二维数组存图,low记录每2个点间最小权值,vis标记某点是否已访问
int n,low[125];

int prim()
{
	int i,j,min,pos,sum=0;
	memset(vis,0,sizeof(vis));
	vis[1]=1;	pos=1;    	//从某点开始,分别标记vis和记录该点pos
	for(i=1;i<=n;++i)  	//第一次给low数组赋值 map的第一行 
		if(i!=pos)
			low[i]=map[pos][i];
	
	for(i=1;i<n;++i)   //再运行n-1次,一次找一个最小 
	{
		min=INF;    
		for(j=1;j<=n;++j)
		{
			if(vis[j]==0&&low[j]<min)  // 找出最小值min,记录位置pos
			{
				min=low[j];   
				pos=j;
			}
		}
		vis[pos]=1;  //标记该点已访问 
		sum+=min;  //最小权值累加
		for(j=1;j<=n;++j)    //更新权值low 把 map的 pos 行中比对应的 low 小的赋给low 
		{
			if(vis[j]==0&&map[pos][j]<low[j])
			{
				low[j]=map[pos][j];
			}
		}
	}
	return sum;
}

int main()
{
	int MIN;
	while(scanf("%d",&n)!=EOF)
	{
		memset(map,0,sizeof(map));
		for(int i=1;i<=n;++i)
			for(int j=1;j<=n;++j)
				scanf("%d",&map[i][j]);
		MIN=prim();
		printf("%d\n",MIN);
	}
	return 0;
}



已AC代码:克鲁斯卡尔(kruscal)思想

#include<cstdio>
#include<algorithm>
using namespace std;
int per[125];    // 并查集 
int n,m;
struct node{
	int u,v,w;    //w为距离 
}s[10010];

bool cmp(node a,node b)
{
	return a.w<b.w;  
}

void into()     //初始化 
{
	for(int i=0;i<=n;++i)
		per[i]=i;
}

int find(int x)      // 查找根节点 
{
	return x==per[x]?x:per[x]=find(per[x]);
}

bool join(int a,int b)   //合并根节点,并判断是否成环 
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)
	{
		per[fa]=fb;
		return true;
	}
	return false;
}

int main()
{
	int i,j,sum,num;
	while(scanf("%d",&n)!=EOF)
	{
		int k=0;
		for(i=1;i<=n;++i)   //读入数据 
		{
			for(j=1;j<=n;++j)
			{
				scanf("%d",&num);
				if(i>j)   //只读取一半 (i>j)的数据 
				{
					s[k].u=i;
					s[k].v=j;
					s[k].w=num;
					k++;
				}
			}
		}
		
		into();   //初始化根节点 
		sort(s,s+k,cmp);   //按距离从小到大排序 
		
		sum=0;
		for(i=0;i<k;++i)
		{
			if(join(s[i].u,s[i].v))
			{
				sum+=s[i].w;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值