HDOJ 1789 Doing Homework again (贪心&&优先队列)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8990    Accepted Submission(s): 5313


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
注 - 此题为: HDOJ 1789 Doing Homework again (贪心&&优先队列)

题意:给定一系列任务的截至时间 和无法完成的罚分
思路:第N天截至的只能在前N天完成 对于第N天截至的任务 最多只能有N个
超出的必然无法完成 所以对于第N天截至的任务 如果超过N个 那么保留前N大的
后面的必然要罚分 然后从最后一天开始 所有截至日期大于当天的中的罚分最多的任务在当天完成
剩下的继续在下一天继续比较 在开始的时候记录总是罚分sum  用sum减去每次完成的任务的罚分
最后sum即是总是罚分
已AC代码:

#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
struct node{
	int x;
	int y;
}s[1100];
bool cmp(node a,node b)  // 贪心 
{
	if(a.x==b.x)
		return a.y<b.y;
	return a.x<b.x;
}
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		priority_queue<int,vector<int>,greater<int> >Q;  // 优先队列 
		int n,i;
		cin>>n;
		for(i=0;i<n;++i)
			cin>>s[i].x;
		for(i=0;i<n;++i)
			cin>>s[i].y;
		sort(s,s+n,cmp);
		while(!Q.empty()) //清空队列 
			Q.pop();
			
		int sum=0,k;
		for(i=0;i<n;++i)
		{
			if(s[i].x>Q.size())   //队列大小 相当于 时间
				Q.push(s[i].y);
			else
			{
				k=Q.top();
				if(k<s[i].y)  // 队中最小值小于当前分,将当前分进入队列,原来的最小值弹出 即为 罚分 
				{
					Q.pop();  //原来的最小值弹出 即为 罚分 
					sum+=k;    
					Q.push(s[i].y);
				}
				else  // 否则,当前就舍弃 
					sum+=s[i].y;
			}
		}
		cout<<sum<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值