NYOJ 103 A+B Problem II (大数)

A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
注 - 此题为 : NYOJ 103 A+B Problem II (大数)

        大数 a+b  模板   注意格式

已AC代码:

#include<cstdio>
#include<cstring>
#define max(x,y) (x>y?x:y)

char ch1[1100],ch2[1100];
int a[1100],b[1100],la,lb;
int main()
{
	int T,CASE=1,i,j;
	scanf("%d",&T);
	while(T--)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		
		scanf("%s%s",ch1,ch2);
		
		la=strlen(ch1);
		lb=strlen(ch2);
		
		for(i=0,j=la-1;i<la;++i,--j)
			a[j]=ch1[i]-'0';
		for(i=0,j=lb-1;i<lb;++i,--j)
			b[j]=ch2[i]-'0';
			
		int len=max(la,lb);
		for(i=0;i<len;++i)
		{
			a[i]+=b[i];
			if(a[i]>9)  //进位 
			{
				a[i]-=10;
				a[i+1]+=1;
			}
		}
		
		printf("Case %d:\n",CASE++);
		printf("%s + %s = ",ch1,ch2);
		
		for(i=1000;i>=0;--i)
			if(a[i]!=0)
				break;
		for(;i>=0;--i)
			printf("%d",a[i]);
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值