hdu2616 kill the monster 4.3.8

5 篇文章 0 订阅

据说是道dfs水题……

Kill the monster

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 41 Accepted Submission(s): 34
 
Problem Description
There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it. 
Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect.
 
Input
The input contains multiple test cases.
Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has.
Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m).
 
Output
For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.
 
Sample Input
3 100
10 20
45 89
5  40

3 100
10 20
45 90
5 40

3 100
10 20
45 84
5 40
 
Sample Output
3
2
-1
 
    
 

#include <iostream>
using namespace std;
int n,m;
int a[12],b[12];
int hash[12];
int maxx;

void dfs(int s,int m)//number of used spell, remained hp
{
     int i;
     if(s>n)//the number of spell is over
         return;
     if(m<=0)//hp<0
     {
         if(maxx>s)//find a smaller method
             maxx=s;
         return;
     }
     
     for(i=0;i<n;i++)
     {
         if(hash[i])//didn't use this spell
         {
             hash[i]=0;//now use it
             if(m<=b[i])//if left hp is less than double-effect hp
             {
                 dfs(s+1,m-2*a[i]);
             }
             else
                 dfs(s+1,m-a[i]);
             hash[i]=1;//recovery
         }
     }
     return ;
}
             
                 
         


int main()
{
    int i;
    while(cin>>n>>m)
    {
        for(i=0;i<n;i++)
        {
            cin>>a[i]>>b[i];
        }
        memset(hash,1,sizeof(hash));
        maxx=15;
        dfs(0,m);
        if(maxx==15)
        cout<<"-1"<<endl;
        else
        cout<<maxx<<endl;//Presentation Error....shame
    }
    return 0;
}

大家都是怎么看出来什么时候用dfs的呢……

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值