usaco 2.1.4 Healthy Holsteins

surprise!

在nnnnnnn久没码代码然后前两天码了一个还出现了本机和上传结果不符的诡异情况后,今天终于rp爆发了.一次编译过+一次提交过,虽然查逻辑错还是花了挺久,大概有三处,不过还是很满意的,而且第一次用位运算,虽然犯了个2,纠结了好久,但总体还是不错的,虽然害的没睡成午觉...

Healthy Holsteins
Burch & Kolstad

Farmer John prides himself on having the healthiest dairy cows in the world. He knows the vitamin content for one scoop of each feed type and the minimum daily vitamin requirement for the cows. Help Farmer John feed his cows so they stay healthy while minimizing the number of scoops that a cow is fed.

Given the daily requirements of each kind of vitamin that a cow needs, identify the smallest combination of scoops of feed a cow can be fed in order to meet at least the minimum vitamin requirements.

Vitamins are measured in integer units. Cows can be fed at most one scoop of any feed type. It is guaranteed that a solution exists for all contest input data.

PROGRAM NAME: holstein

INPUT FORMAT

Line 1:integer V (1 <= V <= 25), the number of types of vitamins
Line 2:V integers (1 <= each one <= 1000), the minimum requirement for each of the V vitamins that a cow requires each day
Line 3:integer G (1 <= G <= 15), the number of types of feeds available
Lines 4..G+3:V integers (0 <= each one <= 1000), the amount of each vitamin that one scoop of this feed contains. The first line of these G lines describes feed #1; the second line describes feed #2; and so on.

SAMPLE INPUT (file holstein.in)

4
100 200 300 400
3
50   50  50  50
200 300 200 300
900 150 389 399

OUTPUT FORMAT

The output is a single line of output that contains:

  • the minimum number of scoops a cow must eat, followed by:
  • a SORTED list (from smallest to largest) of the feed types the cow is given
If more than one set of feedtypes yield a minimum of scoops, choose the set with the smallest feedtype numbers.

SAMPLE OUTPUT (file holstein.out)

2 1 3

喵~

/*
ID: wtff0411
PROG: holstein
LANG: C++
*/
#include <iostream>
#include <fstream>
#include <string>
#include <cstring>
#include <vector>
#include <cmath>
#include <queue>
#include <algorithm>

using namespace std;

int main()
{
    freopen("holstein.in","r",stdin);
    freopen("holstein.out","w",stdout);
    int v,g;
    int i,j,k;
    int r[100];
    int s[50][50];
    
    cin>>v;
    
    for(i=0;i<v;i++)
    cin>>r[i];
    cin>>g;
    for(i=0;i<g;i++)
        for(j=0;j<v;j++)
           cin>>s[i][j];
    int m=pow(2.0,(double)g);
    int resn=100,ress=1000000;
    for(i=1;i<m;i++)
    {
        int tempr[100];
        memset(tempr,0,sizeof(tempr));
        int tempn=0;
        int temp=i;
        for(j=0;j<g;j++)
        {
            if(temp&1)
            {
            for(k=0;k<v;k++)
            {
                tempr[k]+=s[j][k];
                
            }
            tempn++;
            }
            if(tempn>resn)break;
            temp=temp>>1;//aha shit
        }
        
        bool flag=false;
        for(k=0;k<v;k++)
            {
                if(tempr[k]<r[k])
               { flag=true;
               break;
               }
            }
         //  cout<<tempn<<endl; 
        if(flag==false&&((tempn<resn)||((tempn==resn)&&(i<ress))))
        {
            
            resn=tempn;
            ress=i;
        }
        
    }
    cout<<resn;
    for(j=1;j<=g;j++)
        {
        if(ress&1)
            {
                  cout<<" "<<j;
            }
            ress=ress>>1;
        }
        cout<<endl;//well...- -that's it
    //system("pause");
    return 0;
}
码代码..只要自己逻辑比较清晰,最后能出正确的结果,果然还是一件很爽的事...

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值