android studio 遇到的bug 收集

问题 1

Error:Execution failed for task ':App_ShippingCity:dexRelease'.
> java.util.zip.ZipException: error in opening zip file
on timeout.)
<a href="syncProject">Re-download dependencies and sync project (requires network)</a>
<a href="syncProject">Re-download dependencies and sync project (requires network)</a>

包重复了,support-v4包重复

有时会遇到 以下错误,也是v4包重复错误

Error:Error converting bytecode to dex:
Cause: com.android.dex.DexException: Multiple dex files define
Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoVersionImpl;

由于你引用的包里面有引用了v4导致的

直接在android studio 中使用 gradlew -q :projectName:dependencies (projectName为你的项目名)查看包应用


+--- com.yancy.imageselector:imageselector:1.3.3
|    \--- com.android.support:appcompat-v7:22.2.1
|         \--- com.android.support:support-v4:22.2.1 -> 23.2.1
|              \--- com.android.support:support-annotations:23.2.1

通过
compile('com.yancy.imageselector:imageselector:1.3.3') {
        exclude module: 'support-v4'
    }
进行设置即可

-----------------------------------------------------------------
问题 2


Error:Execution failed for task ':App_ShippingCity:transformClassesWithDexForDebug'.
> com.android.build.api.transform.TransformException:
com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException:
Process 'command 'C:\Program Files\Java\jdk1.7.0_17\bin\java.exe'' finished with non-zero exit value 2

(1)jar包的重复添加

(2)添加
    defaultConfig {
        // Enabling multidex support.
        multiDexEnabled true
    }

------------------------------------------------------------------------------------------------------

问题 3


Error:Error: Expected resource of type id [ResourceType]

在android studio 中出现向id传num报错的时候,点击灯泡选择Disable inspection 进行忽略这个错误

--------------------------------------------------------------------------------------------------------
问题 4


Error:(3) Error: "reason" is not translated in "en" (English) [MissingTranslation]

在 <resources> 中添加以下内容

    xmlns:tools="http://schemas.android.com/tools"
    tools:locale="en"

-----------------------------------------------------------------------------------------------------

问题 5


Error:java.io.IOException:
Can't read
[F:\MyApplication\App_ShippingCity\build\intermediates\exploded-aar\
MyApplication\ShippingCity_App_Lib\unspecified\jars\libs\android-support-v4.jar(;;;;;;!META-INF/MANIFEST.MF)]
(Duplicate zip entry [android-support-v4.jar:android/support/v4/print/PrintHelper$1.class])

在  packagingOptions 中添加

        exclude '!META-INF/MANIFEST.MF'
        exclude 'META-INF/MANIFEST.MF'

主要还是 supportv4包重复

------------------------------------------------------------------------------------------------------

问题 6

友盟统计,不需要导入jar包直接进行  
dependencies {
   compile 'com.umeng.analytics:analytics:latest.integration'
}
的配置即可

------------------------------------------------------------------------------------------------------

问题 7

在android studio 1.5 升级成为  2.1.3 的时候出现了这个问题内存不足

方法一:

在project 中的gradle.properties  文件里面 添加 <pre style="background-color:#2b2b2b;color:#a9b7c6;font-family:'Courier New';font-size:10.5pt;"><span style="color:#cc7832;background-color:#344134;">org.gradle.jvmargs</span><span style="color:#808080;">=</span><span style="color:#6a8759;">-Xmx1024m -XX</span>\:<span style="color:#6a8759;">MaxPermSize</span>\=<span style="color:#6a8759;">1024m</span>


要是不行,参考方法二:

1.File->Close Project

2.Configure->Settings

3.在Build,Execution,Deployment ->Compiler 里面 设置

Build process heap size (Mbytes)  的值为1024

Shared build process VM options  的值为  -Xmx1024m

如下图所示

一般到这里可能问题就解决了,但是我的小的项目跑是可以跑起来了,但是大点的项目还是跑步起来,于是将下图所示的勾去掉

 

后面的原因是因为自己的电脑的内存不够导致的

----------------------------------------------------------------------------------------------------------------------------------------------

问题 8

Error:Execution failed for task ':EnvironmentalProtection:transformClassesWithJarMergingForDebug'.
> com.android.build.api.transform.TransformException: java.util.zip.ZipException: duplicate entry: com/bumptech/glide/gifdecoder/GifDecoder$BitmapProvider.class

以上是第三方包重复引入导致的

通过在 android studio 中Terminal   输入  gradlew -q :projectName:dependencies (projectName为你的项目名)查看包应用  得到如下结果

+--- com.zzhoujay.richtext:richtext:2.2.1
|    +--- com.android.support:appcompat-v7:24.0.0 (*)
|    +--- com.github.bumptech.glide:glide:3.7.0
|    \--- com.zzhoujay.markdown:markdown:1.0.0

其中的  richtext 引用了 com.github.bumptech.glide 和其他的引用冲突了,所以只要将

compile ('com.zzhoujay.richtext:richtext') 

改为

compile ('com.zzhoujay.richtext:richtext') {
      exclude group: 'com.github.bumptech.glide:glide'
 }

即可

-------------------------------------------------------------------------------------------

问题 9

Error:Failed to complete Gradle execution.

Cause:
error in opening zip file
s sometimes occurs after a network connection timeout.)
<a href="syncProject">Re-download dependencies and sync project (requires network)</a>
<a href="syncProject">Re-download dependencies and sync project (requires network)</a>


解决方法:

将项目project中的 gradle 文件夹下 wrapper 中的 gradle-wrapper.properties 文件中的

distributionUrl=https\://services.gradle.org/distributions/gradle-2.1-all.zip
改为你项目中设置的gradle的(可以参考之前项目里面的配置)

distributionUrl=https\://services.gradle.org/distributions/gradle-2.2-all.zip

发布了53 篇原创文章 · 获赞 15 · 访问量 7万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览