hdu 1312 Red and Black

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output
45
59
6
13

解题思路:在每个位置都有上下左右四种走法;对四个位置都进行判断,若能走(为黑色);
则继续对四个位置进行判断(递归),走过这点就将该点改变,避免重复走

代码如下

#include<stdio.h>

void BFS(int x,int y);            //广搜

char str[21][21];

int num[4][2] = {{-1,0},{1,0},{0,-1},{0,1}};   //依次对应上下左右4个方向
int W,H,count;

int main()
{
    int i,j;
    int x,y;
    while(~scanf("%d%d",&W,&H))
    {
        getchar();                      //吸收换行
        if(W == 0 && H == 0) break;
        for(i = 0 ; i < H ; i++)
        {
            for(j = 0 ; j < W ; j++)
            {
                scanf("%c",&str[i][j]);
                if(str[i][j] == '@')    //标记起始位置
                {
                    x = i;
                    y = j;
                }
            }
            getchar();              //吸收换行
        }
        count = 0;
        BFS(x,y);
        printf("%d\n",count);
    }
    return 0;
}

void BFS(int x,int y)
{
    int x1,y1,i;
    str[x][y] = '#';            //每走过一个位置,将该位置变色,避免重复走
    count++;
    for(i = 0 ; i < 4 ; i++)
    {
        x1 = x+num[i][0];
        y1 = y+num[i][1];
        if(x1 >= 0&&y1 >= 0&&x1 < H&&y1 < W&&str[x1][y1] == '.')
            BFS(x1,y1);         //递归开始广搜
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值