S - Picture

Give you the width and height of the rectangle,darw it. InputInput contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.OutputFor each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+
|   |
|   |
+---+
一道很简单的题,我WA了好多次,初始化的时候一直写成了char p[100][100]={‘ ’};,这是错误的!!!还要注意的是题里对格式的要求,每个测例后面要有空行!!!最开始没注意到这个PE了……
#include <stdio.h>
#include <stdlib.h>

int main()
{
    int m,n,i,j;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        char p[100][100];
        for(i=0;i<m+2;i++)
        {
        	for(j=0;j<n+2;j++)
        	{
        		p[i][j]=' ';
		}
	}
        p[0][0]='+';p[0][n+1]='+';p[m+1][0]='+';p[m+1][n+1]='+';
        for(i=1;i<=n;i++)
        {
            p[0][i]='-';
            p[m+1][i]='-';
        }
        for(i=1;i<=m;i++)
        {
            p[i][0]='|';
            p[i][n+1]='|';
        }
        for(i=0;i<m+2;i++)
        {
            for(j=0;j<n+2;j++)
            {
                printf("%c",p[i][j]);
            }
            printf("\n");
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值