一、Y - A == B ?

Y - A == B ?

HDU - 2054

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

Sample Input

1 2
2 2
3 3
4 3

Sample Output

NO
YES
YES
NO

 

题意很简单,给你两个数字,问他们是否相等

思路:肯定是非常大的数,所以用字符串存储。然后对字符串进行处理,处理方法:

①删掉数字前无意义的0

②删掉小数点后数字最后的0 

比较时用字符串比较函数即可。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

void change(char s[]);

int main()
{
    char a[50000],b[50000];
    while(scanf("%s%s",a,b)!=EOF)
    {
        change(a);
        change(b);
        if(strcmp(a,b))
        {
            printf("NO\n");
        }
        else
        {
            printf("YES\n");
        }
    }
    return 0;
}
void change(char s[])
{
    int l,i=0,flag=0;
    l=strlen(s);
    if(strchr(s,'.')!=NULL)
    {
        while(s[l-1]=='0')
        {
        	s[l-1]='\0';
            l--;
        }
        if(s[l-1]=='.')
        {
            s[l-1]='\0';
        }
    }
    char *p=s;
    while(*p=='0') p++;
    strcpy(s,p);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值