一、Z - A + B Problem II

Z - A + B Problem II

HDU - 1002

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

很明显的大数加法

 思路:两个数的长度不一定相同,我以长度较长的数为基准,将较短的数往上加。注意细节即可。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <memory.h>

int main()
{
    int i,j,t,l1,l2;
    char a[1001],b[1001];
    int ans[1002];
    memset(ans,0,sizeof(ans));
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
        scanf("%s%s",a,b);
        l1=strlen(a);
        l2=strlen(b);
        if(l1>=l2)
        {
            for(j=l1-1;j>=0;j--)
            {
                ans[j+1]=a[j]-'0';
            }
            for(j=l1-1;j>=l1-l2;j--)
            {
                ans[j+1]+=b[j-l1+l2]-'0';
                if(ans[j+1]>9)
                {
                    ans[j]++;
                    ans[j+1]=ans[j+1]%10;
                }
            }
        }
        else
        {
            for(j=l2-1;j>=0;j--)
            {
                ans[j+1]=b[j]-'0';
            }
            for(j=l2-1;j>=l2-l1;j--)
            {
                ans[j+1]+=a[j-l2+l1]-'0';
                if(ans[j+1]>9)
                {
                    ans[j]++;
                    ans[j+1]=ans[j+1]%10;
                }
            }
        }
        printf("Case %d:\n%s + %s = ",i,a,b);
        for(j=0;j<=(l1>l2?l1:l2);j++)
        {
            if(j==0&&ans[j]==0) continue;
        	printf("%d",ans[j]);
		}

        printf("\n");
        if(i!=t) printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值