解决微信开发者工具当前系统代理不是安全代理

微信小程序开发工具登录时,有时会遇到提示当前系统代理不是安全代理 是否信任 ,然后我们点击确认,却弹出Error:unable to verify the first certificate。这时无论我们在左上角选择设置是否选用代理都无法解决。本人曾经也很困惑,后来知道这是微信小程序开发者工具,为了信息的安全性,检查了系统代理,至于为什么选择不使用代理同样不行,就不得而知了。不过没事,现在解决了,所以拿出来和大家分享下。

 

1,在电脑左下角开始处点开输入regedit或按快捷键win+R然后输入regedit,打开注册表编辑器

2,通过下面的路径打开

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Internet Settings,这时界面如下(注每个人里面项会有稍微不同,不重要)

 

3,这时把里面所有的Proxy开头的项都删除掉,如

ProxyEnable

ProxyOverride

有些人的还有ProxyServer等。(如果你怕删除后会对其他软件有影响,你可以重命名这些项,如改成ReProxy开头等,方便改回来。)

 

4,删除成功后,一定要注销或者重启电脑,重启或注销电脑后再打开微信小程序开发工具,扫描登录就可以登录了,下次登录如果再遇到相同问题,重新按这个步骤操作一次即可(因为可能你的其他软件又把这些项写进去了)。

发布了14 篇原创文章 · 获赞 14 · 访问量 5万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览