hdu1894String Compare

18 篇文章 0 订阅
9 篇文章 0 订阅

String Compare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2920    Accepted Submission(s): 696

Problem Description
Maybe there are 750,000 words in English and some words are prefix of other words, for example: the word "acm" can be treat as one prefix of "acmicpc". What's more, most of such pairs of words have relationship between them. Now give you a dictionary, your work is to tell me how many such pairs.


There may be other characters in the word, for example '_','-',and so on.
Pay attention that 'A' and 'a' are not the same character!
 


 

Input
In the first line of the input file there is an Integer T, which means the number of test cases. Followed by T test cases.
For each test case, in the first line there is an integer N(0<N<=50000), followed N lines, each contains a word whose length is less than 30 and no space appears in any word. There are no same words in two different lines.
 


 

Output
For each test case, tell me how many such pairs. If the number is larger than 11519, just divide it by 11519 and only output the remainder.
 


 

Sample Input
  
  
2 2 acmicpc acm 3 a abc ab
 


 

Sample Output
  
  
1 3
 


 

Author
Sempr|CrazyBird|hust07p43
 


 

Source

 

#include"iostream"
#include"stdio.h"
#include"stdlib.h"
#include"string.h"
#include"algorithm"
using namespace std;
struct node
{
    char a[30];
}word[50005];
bool cmp(node a1,node b1)
{
    return strcmp(a1.a,b1.a)<0;
}
int main(int argc, char* argv[])
{
    int n,m,temp;
    int i,j,k,len,s;
    
    cin>>n;//输入用例个数
    while(n--)
    {
        s=0;
        scanf("%d",&m);//输入单词个数
        for(i=0;i<m;i++)
        scanf("%s",word[i].a);
        sort(word,word+m,cmp);//对单词从小到大排序
        for(i=0;i<m-1;i++)//从第一个即最小的单词开始
        {
            len=strlen(word[i].a);
            for(j=i+1;j<m;j++)//从它的下一个单词开始依次与之比较
            {
                for(k=0;k<len;k++)//从第一个字母开始依次向后
                {
                    if(word[i].a[k]==word[j].a[k])
                        ;
                    else
                        break;
                }
                if(k==len)
                    s++;
                else
                    break;
            }
        
        }
        if(s>11519)
                s=s%11519;
        printf("%d\n",s);
    }
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值