poj 1159 Palindrome

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 50887 Accepted: 17525

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

IOI 2000

【题意分析】
转载:http://www.cnblogs.com/rainydays/archive/2011/06/24/2089326.html

题意:求对字符串最少添加几个字符可变为回文串。

分析:简单做法是直接对它和它的逆序串求最长公共子序列长度len。n-len即为所求。(n为原串长度)

这样做的原因如下:

要求最少添加几个字符,我们可以先从原串中找到一个最长回文串,然后对于原串中不属于这个回文串的字符,在它关于回文串中心的对称位置添加一个相同字符即可。那么需要添加的字符数量即为n-最长回文串长度。

最长回文串可以看作是原串中前面和后面字符的一种匹配(每个后面的字符在前面找到一个符合位置要求的与它相同的字符)。这种的回文匹配和原串与逆序串的公共子序列是一一对应的(一个回文匹配对应一个公共子序列,反之亦然),而且两者所涉及到的原串中的字符数量是相等的,也就是最长公共子序列对应最长回文串。原因陈述完毕。

【代码】
我先用二维LCS做,因为二维比较直观,但是切不过,因为测试数据比较强大。


#include<iostream>
#include<stack>
#include<iomanip>
#include<string>
int c[100][100] = {0};
using namespace std;
int LCS(string s,string s1){
	int m = s.size();
	int n = s1.size();
	for(int i=1;i<=m;i++){
		for(int j=1;j<=n;j++){
			if(s[i-1]==s1[j-1]){
				c[i][j] = c[i-1][j-1]+1;
			}
			else if(c[i-1][j]>=c[i][j-1])
				c[i][j] = c[i-1][j];
			else c[i][j] = c[i][j-1];
		}
	}
	return c[m][n];
}
int main(void){
	int n;
	string s;
	while(cin>>n>>s){
		string s1(s);
		for(int i=0;i<n;i++){
			s1[i] = s[n-1-i];
		}
		int ans = LCS(s,s1);
		cout<<n-ans<<endl;
	}
	return 0;
}
	

算法取自算法导论

改进成行数为2的代码
因为每个c[i][j] 仅依赖与 c[i-1][j] 和 c[i-1][j-1]  和 c[i][j-1]  所以只需要做两行的数组即可

#include<iostream>
#include<stack>
#include<iomanip>
#include<string>
int c[2][5001] = {0};
using namespace std;
int LCS(string s,string s1){
	int m = s.size();
	int n = s1.size();
	int e =1;
	for(int i=1;i<=m;i++){
		e = 1-e;
		for(int j=1;j<=n;j++){
			if(s[i-1]==s1[j-1]){
				c[e][j] = c[1-e][j-1]+1;
			}
			else if(c[1-e][j]>=c[e][j-1])
				c[e][j] = c[1-e][j];
			else c[e][j] = c[e][j-1];
		}
	}
	return c[e][n];
}
int main(void){
	int n;
	string s;
	while(cin>>n>>s){
		string s1(s);
		for(int i=0;i<n;i++){
			s1[i] = s[n-1-i];
		}
		int ans = LCS(s,s1);
		cout<<n-ans<<endl;
	}
	return 0;
}
	

一次AC,yeah~


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值