HDOJ1002(大数相加)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 356833    Accepted Submission(s): 69210


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

思路:

问题描述:大数相加超出Int范围,考虑从个位数相加开始,并将每一位存放在int类型的数组中。

注意:

1.两个数的位数可能不同;

2.结果位数可能增加;

#include <iostream>
#include <string>
using namespace std;
int main()
{
	int sum[1001],len1,len2,d;
	int n = 0,index = 1,k =0;
	string str1,str2;
	cin>>n;
	while(n--)
	{
		d = 0;
		cin>>str1>>str2;
		for(len1= str1.size()-1,len2 = str2.size()-1,k = 0;len1 >=0 && len2 >= 0;len1--,len2--,k++)
		{
			d = str1[len1] - '0' + str2[len2] - '0' + d;
			sum[k]=d % 10;
			d = d /10; 
		}
		if(k ==str1.size())
		{
			while(len2 >= 0)
			{
				d = str2[len2--]-'0'+d;
				sum[k++] = d % 10;
				d = d /10;
			}
		}else
		{
			while(len1 >=0)
			{
				d = str1[len1--] - '0' + d;
				sum[k++] = d %10;
				d = d / 10;
			}

		}
		if(d != 0)
		{
			sum[k++] = d;
		}
		cout<<"Case "<<index<<":"<<endl;
		cout<<str1<<" + "<<str2<<" = ";
		for (int j = k-1;j >= 0;j--)
			cout<<sum[j];
		cout<<endl;
		if(0 != n)
			cout<<endl;
		++index;
	}
	return 0;
}



注意:输出的结果每一行之间都需要空一行,最后一个输出不需要

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值