poj3617字典序问题【贪心】

Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16664 Accepted: 4692

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD



中文意思:

每次都可以从字符串的首部或者尾部提取字母,使得最后的字符串的字典序最小。


!!!好大一个坑…字符输入是一个一个的!!!

可以用cin.getline();但是时间慢,           也可以用 scanf("%s", tmp);s[i] = tmp[0];

参考了网上的思路发现,还可以用scanf(" %c", &ch);

在格式串中,空格的意思是匹配输入中的所有换行、TAB、空格,所以加上一个空格,就可以屏蔽掉在输入中的所有的不愉快的因素了。

我的代码是按照快速排序的…然而超时,附在最后……

下面这个代码是参考《挑战编程》的思路

#include <stdio.h>
#include <string.h>
char s[2002];
int main(){
int n;
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=0;i<n;i++){
			scanf(" %c",&s[i]);	//前面的空格用来匹配空白符号 
		}
		
		int a=0,b=n-1;
		int ans=0;
		while(a<=b){
			bool left=false;		
			for(int i=0;a+i<=b;i++){		//字符串反转比较 
				if(s[a+i]<s[b-i]){
					left=true;
					break;
				}
				else if(s[a+i]>s[b-i]){
					left=false;
					break;
				}
			}
			if(left)  putchar(s[a++]);
			else putchar(s[b--]); 
			ans++;
			if(ans==80){
				printf("\n");
				ans=0;
			} 	
		}	
		  printf("\n");	
	}
	return 0;
}


这个是我的代码,按照快速排序的思想…然而超时了超时了TT…

#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;

int main(){
	int n;
	char x[2002],y[2002];
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf(" %c",&x[i]);	//前面的空格用来匹配空白符号 
	}

	for(int i=0,j=n-1,k=0;i<=j;){
		while(x[i]<x[j]||(x[i]==x[j]&&x[i+1]<x[j-1])){
			y[k++]=x[i];
			i++;
		}
		while(x[i]>x[j]||(x[i]==x[j]&&x[i+1]>x[j-1])){
			y[k++]=x[j];
			j--;
		}
	}
	for(int i=0;i<n;i++){
		printf("%c",y[i]);
	}
	return 0;
}

 






  • 0
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短路径。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值