数论算法总结01

欧拉函数及欧拉公式

欧拉函数:ph(n)的意思是所有小于n且与n互质的数的个数。

比如说ph(12)=4。[1,5,7,11与12互质]

欧拉公式

a^ph(m)=1(mod m)

Fibonacci相关问题

1. 整除问题

第一种hdu 1021为例,

hdu 1021 FibonacciAgain

Problem Description

There are another kind ofFibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

 Input

Input consists of a sequenceof lines, each containing an integer n. (n < 1,000,000).

 Output

Print the word"yes" if 3 divide evenly into F(n).
Print the word "no" if not.

Sample Input

0
1
2
3
4
5

 Sample Output

no
no
yes
no
no
no

解题报告:

相关知识补充:
同于公式( a + b ) % 3 = ( a % 3 + b % 3) % 3
类似此题的解决方法有两个:
方法一、利用同于公式,代码如下:
#include <iostream>
#include <stdio.h>
using namespace std;
int f[1000100];
int main()
{
f[0]=1; f[1]=2;
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=2;i<=n;i++)
{
f[i] = (f[i-1]+f[i-2])%3;
}
if(f[n]%3==0)
printf("yes\n");
else
printf("no\n");
}
return 0;
}
 
方法二、找规律,也可以用来打表。代码如下:
#include<stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n%4==2) printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值