三点顺序
时间限制:1000 ms | 内存限制:65535 KB
难度:3
描述
现在给你不共线的三个点A,B,C的坐标,它们一定能组成一个三角形,现在让你判断A,B,C是顺时针给出的还是逆时针给出的?
如:
图1:顺时针给出
图2:逆时针给出
上传失败 <图1> 上传失败 <图2>
输入
每行是一组测试数据,有6个整数x1,y1,x2,y2,x3,y3分别表示A,B,C三个点的横纵坐标。(坐标值都在0到10000之间)
输入0 0 0 0 0 0表示输入结束
测试数据不超过10000组
输出
如果这三个点是顺时针给出的,请输出1,逆时针给出则输出0
样例输入
0 0 1 1 1 3
0 1 1 0 0 0
0 0 0 0 0 0
样例输出
0
1
import java.util.Scanner;
public class TriangleVector {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
while (true) {
int x1 = scanner.nextInt();
int y1 = scanner.nextInt();
int x2 = scanner.nextInt();
int y2 = scanner.nextInt();
int x3 = scanner.nextInt();
int y3 = scanner.nextInt();
if (x1 == 0 && y1 == 0 && x2 == 0 && y2 == 0 && x3 == 0 && y3 == 0) {
break;
}
result(x1, y1, x2, y2, x3, y3);
}
}
private static void result(int x1, int y1, int x2, int y2, int x3, int y3) {
//则AB和AC的叉积为:(2*2的行列式)
int result = (x2 - x1) * (y3 - y1) - (y2 - y1) * (x3 - x1);
if (result > 0) {
System.out.println(0);
} else if (result < 0) {
System.out.println(1);
}
}
}