HUST-1600 - Lucky Numbers 深搜

1600 - Lucky Numbers

时间限制:2秒 内存限制:64兆
416 次提交 115 次通过
题目描述
Isun loves digit 4 and 8 very much. He thinks a number is lucky only if the number satisfy the following conditions:
1. The number only consists of digit 4 and 8.
2. The number multiples 48.
One day, the math teacher gives Isun a problem:
Given L and R(1 <= L <= R <= 10^15), how many lucky numbers are there between L and R. (i.e. how many x satisfy L <= x <= R, x is a lucky number).
输入
Multiple test cases. For each test case, there is only one line consist two numbers L and R.
输出
For each test case, print the number of lucky numbers in one line.

Do use the %lld specifier or cin/ cout stream to read or write 64-bit integers in С++.
样例输入
1 48
1 484848
样例输出
1
7
提示

来源
Problem Setter : Yang Xiao

题意:输入两个数字,表示一个范围,求这个范围内能被48整除,并且只包含4或者8的数字的个数。

解析:构造由4和8组成的数字,判断是否能被48整除并且在输入要求的范围之内,符合条件则计数。当数字超出上界m时,需返回。

根据以上的思路,然后写成代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
int cnt;
void f(long long int n,long long int m,long long int sum)
{
    if(sum%48==0&&sum<=m&&sum>=n) {cnt++;}
    if(sum>m) return;
    for(int i=1;i<=2;i++)
    {
        sum=sum*10+4*i;
         f(n,m,sum);
         sum=(sum-4*i)/10;
    }
}
int main()
{
    long long int n,m,s1,s2;
    while(~scanf("%lld%lld",&n,&m))
    {
     cnt=0;
     f(n,m,0);
     printf("%d\n",cnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值