poj-1125-Stockbroker Grapevine(floyd算法最短路)

Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34000 Accepted: 18794

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2

3 10


题意:

已知n个顶点,随后n行为对应第i个顶点的信息,每行第一个数表示与第i个顶点相邻的顶点个数m,随后给出m条边的信息,每条边的信息包括终点,以及权值,求图中是否存在一个顶点p,使得p可以到达其他任意的顶点,并且到达任意顶点最多耗时最小.


题目链接:Stockbroker Grapevine


解题思路:

对于任意一个顶点p,求出它到其它顶点的最短距离,然后保留最长的那段距离,依次比较其他所有顶点对应的距离,取最小的为结果。


因为要求出两两顶点之间的最短距离,所以可用Floyd算法,先把图给建立出来,然后将可以到达其余所有顶点的点p求出来,保留其对应的最优距离mx,在这些可行的顶点中,再取最小的mx即可。


代码:

#include<cstdio> 
#include<algorithm>

using namespace std;
const int MAX = 1e7;
int n,path[110][110];

void init()
{
    for(int i = 1;i <= n;i++) {
        for(int j = 1;j <= n;j++) {
            path[i][j] = MAX;   //初始化,顶点i -> j 为无穷
        }
    }
}

void floyd()    //Floyd算法
{
    for(int k = 1;k <= n;k++) {
        for(int i = 1;i <= n ;i++) {
            for(int j = 1;j <= n ;j++ ) {
                if(path[i][j] > path[i][k] + path[k][j])
                    path[i][j] = path[i][k] + path[k][j];
            }
        }
    }
}

void solve()
{
    int num = 0,mx = MAX,t,f;
    for(int i = 1;i <= n;i++) { //枚举所有顶点
        t = 0;
        f = 0;
        for(int j = 1;j <= n;j++){  //检查是否可以到达其他所有顶点
            if(i == j) continue;
            if(path[i][j] == MAX) { //有一个顶点不能到达,则不可取
                f = 0;
                break;
            }
            t = max(t,path[i][j]);  //取该顶点i遍历所有任意顶点的最短时间
            f = 1;
        }
        if(t < mx && f) {   //所有满足条件的顶点,取耗时最小的
            mx = t,num = i;
        }
    }
    if(!num) {      //非连通图
        printf("disjoint\n");
        return;
    }
    printf("%d %d\n",num,mx);
}

int main()
{
    int m,st,cos;
    while(~scanf("%d",&n) && n) {
        init();
        for(int i = 1;i <= n;i++) {
            scanf("%d",&m);
            while(m --) {
                scanf("%d%d",&st,&cos);
                path[i][st] = cos;  //点i 到点st 有一条权值为cos的边
            }
        }
        floyd();
        solve();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值