PAT-甲级-1002 A+B for Polynomials

题目

1002 A+B for Polynomials (25)(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

题目分析 

题目的意思是,每一行第一个是多项式的项数,后面跟着的是指数和系数

例:2 2 3 1 1.5  即表示一个有两项的多项式 3x^2+1.5x^1

输出是将两个多项式相加,以相同的格式输出多项式。并且指数大的在前面。

思路

以数组a[1001]的下标为指数,系数存进数组,写第二个的时候加进去。

注意数组初始化为0。输出时先遍历一遍数组计算非0的项的数目,即多项式数目,然后再遍历一遍输出结果,结果即值非零的下标i(指数)和值(系数)。 

代码

#include<stdio.h>
#include<iostream>
#include <stdlib.h>
#include<iomanip>
using namespace std;
int main(){
    float a[1001]={0};
    int n1,n2,i;
    int t1,sum = 0;
    float t2;
    cin>>n1;
    for(i = 0;i<n1;i++){
        cin>>t1>>t2;
        a[t1]+= t2;
    }
    cin>>n2;
    for(i = 0;i<n2;i++){
        cin>>t1>>t2;
        a[t1]+= t2;
    }
    for(i = 0;i<1001;i++){
        if(a[i]) sum++;
    }
    cout<<sum;
    if(sum == 0){
    //    cout<<endl;
        return 0;
    }
    int s = 0;
    for(i = 1000;i>=0;i--){
        if(a[i]) {
          //  cout<<" "<<i<<" "<< fixed <<setprecision(2)<<a[i];
            printf(" %d %.1f", i, a[i]);
         //   if(s<sum)  cout<<" ";
        }
    }
    return 0;
}

问题

遇到的问题主要有两个:

1.数据输入问题。后来发现是变量类型写错了。

2.数据输出问题。用cout时小数点的问题,还有空格是什么时候输出的。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值