Poj 2104 K-th Number(主席树&&整体二分)

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Case Time Limit: 2000MS
Description
You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
Input
The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).
Output
For each question output the answer to it — the k-th number in sorted a[i…j] segment.
Sample Input
7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3
Sample Output
5
6
3
Hint
This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
Source
Northeastern Europe 2004, Northern Subregion

/*
主席树 静态第K小.
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 100001
using namespace std;
int n,m,root[MAXN],cut,a[MAXN],s[MAXN];
struct data{int lc,rc,ans;}tree[MAXN*20];
int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9') {if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9') x=x*10+ch-48,ch=getchar();
    return x*f;
}
void add(int &now,int last,int l,int r,int x)
{
    now=++cut;tree[now].ans=tree[last].ans+1;
    tree[now].lc=tree[last].lc,tree[now].rc=tree[last].rc;
    if(l==r) return ;
    int mid=(l+r)>>1;
    if(x<=mid) add(tree[now].lc,tree[last].lc,l,mid,x);
    else add(tree[now].rc,tree[last].rc,mid+1,r,x);
    return ;
}
int query(int L,int R,int l,int r,int x)
{
    if(l==r) return l;
    int p=tree[tree[R].lc].ans-tree[tree[L].lc].ans;//左树中数的个数.
    int mid=(l+r)>>1;
    if(p>=x) return query(tree[L].lc,tree[R].lc,l,mid,x);
    else return query(tree[L].rc,tree[R].rc,mid+1,r,x-p);
}
int main()
{
    int t; 
    int x,y,z;//t=read();
     while(scanf("%d%d",&n,&m)!=EOF)
     //(t--)
     {
        n=read(),m=read();
        cut=0;memset(root,0,sizeof root);
        for(int i=1;i<=n;i++) s[i]=a[i]=read();
        sort(s+1,s+n+1);
        for(int i=1;i<=n;i++)
        {
            int p=lower_bound(s+1,s+n+1,a[i])-s;
            add(root[i],root[i-1],1,n,p);
        }
        while(m--)
        {
            x=read(),y=read(),z=read();
            //z=(y-x+1)-z+1;
            int p=query(root[x-1],root[y],1,n,z);
            printf("%d\n",s[p]);
        }
    }
    return 0;
}
/*
求静态区间第K小. 
整体二分.
二分出一个答案然后统计贡献.
对多个操作同时处理. 
然后使操作有序化.
树状数组维护一段值域区间内数的个数.
还是比较模糊orz.
*/
#include<iostream>
#include<cstdio>
#define MAXN 200001
#define INF 1e9
using namespace std;
struct data{int x,y,k,s,o,cut;}
q[MAXN],tmp1[MAXN],tmp2[MAXN];
int n,m,tot,s[MAXN],ans[MAXN],a[MAXN],tmp[MAXN];
int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9') x=x*10+ch-48,ch=getchar();
    return x*f;
}
void add(int x,int z)
{
    while(x<=n) s[x]+=z,x+=x&-x;
    return ;
}
int getsum(int x)
{
    int sum=0;
    while(x>0) sum+=s[x],x-=x&-x;
    return sum;
}
void slove(int head,int tail,int l,int r)
{
    if(head>tail) return ;
    if(l==r)
    {
        for(int i=head;i<=tail;i++)
          if(q[i].o==3) ans[q[i].s]=l;
        return ;
    }
    int mid=(l+r)>>1;
    for(int i=head;i<=tail;i++)//统计贡献.
    {
        if(q[i].o==1&&q[i].y<=mid) add(q[i].x,1);
        else if(q[i].o==3) tmp[i]=getsum(q[i].y)-getsum(q[i].x-1);
    }
    for(int i=head;i<=tail;i++)
      if(q[i].y<=mid&&q[i].o==1) add(q[i].x,-1);
    int l1=0,l2=0;
    for(int i=head;i<=tail;i++)
    {//检验 对于该操作找一个所属答案位置.
        if(q[i].o==3)
        {
            if(q[i].cut+tmp[i]>=q[i].k) tmp1[++l1]=q[i];
            //ans 偏大 放入[l,mid]区间查询. 
            else q[i].cut+=tmp[i],tmp2[++l2]=q[i];
            //ans 偏小 放入[mid+1,r]区间查询. 
        }
        else
        {
            if(q[i].y<=mid) tmp1[++l1]=q[i];
            else tmp2[++l2]=q[i];
        }
    }
    for(int i=1;i<=l1;i++) q[head+i-1]=tmp1[i];
    for(int i=1;i<=l2;i++) q[head+l1+i-1]=tmp2[i];
    slove(head,head+l1-1,l,mid),slove(head+l1,tail,mid+1,r);
    return ;
}
int main()
{
    int x,y,z,t=0;char ch[11];
    n=read(),m=read();
    for(int i=1;i<=n;i++)
    {
        a[i]=read();
        q[++tot].x=i,q[tot].y=a[i];
        q[tot].o=1,q[tot].s=0;
    }
    while(m--)
    {
        x=read(),y=read(),z=read();
        q[++tot].x=x,q[tot].y=y,q[tot].k=z;
        q[tot].o=3;q[tot].s=++t;
    }
    slove(1,tot,-INF,INF);
    for(int i=1;i<=t;i++) printf("%d\n",ans[i]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值