今日头条2018校园招聘第一题 ---POJ 2479

第一次参加公司的招聘笔试,虽然只是抱着试试水的心态去参加的,可惜的是第一题就做错了。。。。。
第一题,其实只是一个求最大子段和的变式题,不过笔试的时候也不知道怎么了,就是不知道思路,最后还写了一个错的思路
题目大意:笔试题是求两个不相邻区间的最大子段和, OJ题是不相交区间的最大子段和
思路:很简单,遍历一遍,记录从前往后每个元素以该元素结尾的最大子段和,从后往前每个元素以该元素结尾的最大字段和,
然后一层遍历枚举每一个断点,求出该断点前的最大子段和和断点后的最大子段和最大值









Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41980 Accepted: 13098

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.
Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41980 Accepted: 13098

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<sstream>
#include<cctype>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI=acos(-1.0);
const double eps=1e-6;
const int INF=0x3f3f3f3f;
const int maxn=1234;

int T;
int a[50005];
int b1[50005],b2[50005];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);

        int sum=0;
        int maxs=a[0];
        for(int i=0;i<n;i++)、、从前往后的最大子段和
        {
            sum+=a[i];
            if(sum>maxs) maxs=sum;
            if(sum<0) sum=0;

            b1[i]=maxs;
        }
        sum=0;
        maxs=a[n-1];
        for(int i=n-1;i>=0;i--){//从后往前的最大子段和
            sum+=a[i];
            if(sum>maxs) maxs=sum;
            if(sum<0) sum=0;
            b2[i]=maxs;
        }

       

        int ans=b1[0]+b2[1];
        for(int i=0;i<n-1;i++)
        {
            ans=max(ans,b1[i]+b2[i+1]);
        }

        printf("%d\n",ans);



    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值