HDU 1029 Ignatius and the Princess IV

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 39051    Accepted Submission(s): 17048


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
 
 
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
 
 
3 5 1
 

题意很简答, 给你一个序列,要求找出其中出现次数大于n/2+1的数

这道题有点类似于脑洞题。

有两种解法,第一种是排个序就好了,排序输出最中间的元素即可,由于它出现的次数大于n/2次所以必然在中间。

代码如下:

//#include <bits/stdc++.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <iostream>
#include <queue>
#include <stack>
#include <algorithm>
#include <map>
#define __max(a,b)  (((a) > (b)) ? (a) : (b))
#define __min(a,b)  (((a) < (b)) ? (a) : (b))
using namespace std;
const int maxn = 500;
const int N = 2e6+10;
bool used[N][maxn];
bool Prime[maxn];
char maze[maxn][maxn];
typedef pair<int,int> P;
int dx[] = {-1,0,0,1,0,0};
int dy[] = {0,-1,1,0,0,0};
int dz[] = {0,0,0,0,-1,1};
typedef long long ll;
int t,n,m;
int flag;
int a[N];
int main()
{
    std::ios::sync_with_stdio(false);
    while(cin>>n){
        for(int i = 0; i < n; i++)
            cin>>a[i];
        sort(a,a+n);
        cout<<a[n/2+1]<<endl;
    }
    return 0;
    
}

但因为是归类在dp类的题目里,所以不死心又去搜了题解。

找到了kuangbin巨巨的题解。

多元素即在数列中出现次数多于n/2的元素

我们很容易的看出来,在一个序列中如果去掉2个不同的元素,
那么原序列中的多元素,在新的序列中还是多元素,
因此我们只要按照序列依次扫描,先把t赋值给result,
增加个计数器,cnt = 1;然后向右扫描,
如果跟result相同,则cnt++,不同,那么cnt --,
这个真是我们从上面那个结论里得出的,一旦cnt == 0了,
那么必定c不是多元素,这个时候把t赋值为result,cnt = 1;,
重复该过程,直到结束,这个时候,result就是多元素,
这个的时间复杂度为n
因此我们可以直接按照上述过程计算

然后理解了半天勉强搞懂了。因为要有一个数的出现次数大于个数的一半。

所以cnt--大于0的那个数就是答案。

此外,去掉前部分序列(result和其他数出现次数相同,就只看后半序列即可。

题目没说,但保证了这个数的存在,所以这是正解。

适用于更大范围的题目,那时候会存在数组过大开不了或者快速排序复杂度太高tle的情况。

代码如下:

//#include <bits/stdc++.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <iostream>
#include <queue>
#include <stack>
#include <algorithm>
#include <map>
#define __max(a,b)  (((a) > (b)) ? (a) : (b))
#define __min(a,b)  (((a) < (b)) ? (a) : (b))
using namespace std;
const int maxn = 500;
const int N = 2e6+10;
bool used[N][maxn];
bool Prime[maxn];
char maze[maxn][maxn];
typedef pair<int,int> P;
int dx[] = {-1,0,0,1,0,0};
int dy[] = {0,-1,1,0,0,0};
int dz[] = {0,0,0,0,-1,1};
typedef long long ll;
int t,n,m;
int flag;
int main()
{
    std::ios::sync_with_stdio(false);
    int n,result;
    while(cin>>n){
        int cnt = 0,t;
        for(int i = 0; i < n; i++)
        {
            cin>>t;
            if(cnt == 0)
            {
                result = t;
                cnt = 1;
            }
            else{
                if(t == result)
                    cnt++;
                else cnt--;
            }
        }
        cout<<result<<endl;
    }
    return 0;
}

此外,map也可以水过,或者是开一个数组存每个数出现的次数(hash?)

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值