POJ1611 The Suspects

The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 48037 Accepted: 22992

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

并查集的简单应用。

题意:SARS病毒肆虐,现在已知编号为0的人确诊得病,那么与0同一小组或者是与与0同一个小组的人都是有可能得病的人。

输入一些小组关系,问你suspects有多少个。

那么其实用并查集的思想很方便地就可以做了,如果一个人他的祖先和编号为0的人的祖先一样,那么他就是suspect。

一开始做的时候wa了一次,因为我在判断的时候写成了par[i] == par[0]

后来发现这样是不对的,参考了一些路径压缩的知识,因为有些点的par值并不是最终的祖先

比如以下数据

10 3

2 0 6

2 3 2

2 0 3

那么这组数据的2的par值其实是3(因为路径压缩的时候不能改到这个节点的值)

所以要用Find(i) == par[0],这样就可以了。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#define vi vector<int>
#define P pair<int,int>
using namespace std;
const int MAX_N = 4e4 + 10;
int par[MAX_N];
int Rank[MAX_N];
bool repair[MAX_N];
P p[MAX_N];
int n,m;
void init()
{
    memset(Rank, 0,sizeof(Rank));
    for(int i = 0; i <= n; i++)
        par[i] = i;
}
int Find(int i)
{
    if(par[i] == i)
        return i;
    return par[i] = Find(par[i]);
}
void unite(int x, int y)
{
    x = Find(x);
    y = Find(y);
    if(Rank[x] < Rank[y])
        par[x] = y;
    else
    {
        par[y] = x;
        if(Rank[x] == Rank[y])
            Rank[x]++;
    }
}
bool same(int x, int y)
{
    return Find(x) == Find(y);
}
int main()
{
    // freopen("out.txt","w",stdout);
    ios::sync_with_stdio(false);
    cin.tie(0);
    while(cin >> n >> m && (n || m))
    {
        init();
        int cnt = 0;
        while(m--)
        {
            int k, first;
            cin >> k;
            cin >> first;
            for(int i = 1; i < k; i++)
            {
                int x;
                cin >> x;
                unite(first,x);
            }
        }
        for(int i = 0; i < n ; i++)
        {
            if(Find(i) == par[0])
                cnt++;
        }
        cout << cnt <<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值