HDU1711 Number Sequence(KMP)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 40595    Accepted Submission(s): 16759


Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

 Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 Sample Input

2 
13 5 
1 2 1 2 3 1 2 3 1 3 2 1 2 
1 2 3 1 3 
13 5 
1 2 1 2 3 1 2 3 1 3 2 1 2 
1 2 3 2 1

 Sample Output

6 
-1

Source

HDU 2007-Spring Programming Contest

题意:模式匹配问题。给定两个数组,问你第二个数组在第一个数组中是否出现,求出现的位置。

解法:KMP

由于数据量很大,直接暴力肯定会T。

考虑用kmp在线性时间内求解。

kmp的核心在与next数组和每次匹配时源串的匹配位置。

next数组对匹配子串进行处理,记录其每个位置前缀和后缀相等的长度

 然后再对于字符串原串匹配时,不需要一个位置失配就做1次移动。而是按照前后缀进行移动

找的一个kmp讲解视频理解的:KMP讲解

然后匹配输出即可。

#include <bits/stdc++.h>
#define pii pair<int, int>
#define ll long long
using namespace std;
const int maxn = 1e6 + 10;
int s[maxn], p[maxn];
int Next[maxn];
int n, m;
void get_next()
{
    int i = 1, j = 0;
    Next[0] = 0;
    while(i < m)
    {
        if(p[i] == p[j])
        {
            Next[i] = j + 1;
            i++;
            j++;
        }
        else
        {
            if(j == 0)
            {
                Next[i] = 0;
                i++;
            }
            else
                j = Next[j - 1];
        }
    }
}
int main()
{
    //    freopen("/Users/vector/Desktop/testdata.in", "r", stdin);
    int cas;
    scanf("%d", &cas);
    while(cas--)
    {
        scanf("%d%d", &n, &m);
        for(int i = 0; i < n; i++)
            scanf("%d", s + i);
        for(int i = 0; i < m; i++)
            scanf("%d", p + i);
        get_next();
        int loc = -1;
        int i = 0, j = 0;
        while(i <= n)
        {
            if(j == m)
            {
                loc = i - m + 1;
                break;
            }
            if(s[i] == p[j])
            {
                i++;j++;
            }
            else
            {
                if(j == 0)
                    i++;
                else
                    j = Next[j - 1];
            }
        }
        printf("%d\n", loc);
    }
    
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值