K - Kia's Calculatio

Doctor Ghee is teaching Kia how to calculate the sum of two integers. But Kia is so careless and alway forget to carry a number when the sum of two digits exceeds 9. For example, when she calculates 4567+5789, she will get 9246, and for 1234+9876, she will get 0. Ghee is angry about this, and makes a hard problem for her to solve:
Now Kia has two integers A and B, she can shuffle the digits in each number as she like, but leading zeros are not allowed. That is to say, for A = 11024, she can rearrange the number as 10124, or 41102, or many other, but 02411 is not allowed. 
After she shuffles A and B, she will add them together, in her own way. And what will be the maximum possible sum of A "+" B ?
Input
The rst line has a number T (T <= 25) , indicating the number of test cases. 
For each test case there are two lines. First line has the number A, and the second line has the number B. 
Both A and B will have same number of digits, which is no larger than 10  6, and without leading zeros.
Output
For test case X, output "Case #X: " first, then output the maximum possible sum without leading zeros.
Sample Input
1
5958
3036
Sample Output
Case #1: 8984
Hint


代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;

int a[20];
int b[20];

char A[2000020],B[2000020];
int num1[2000020],num2[2000020];
int ans[2000020];


int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int T;
    int iCase = 0;
    scanf("%d",&T);
    while(T--)
    {
        iCase++;
        scanf("%s%s",A,B);
        int n = strlen(A);
        for(int i = 0;i < n;i++)
        {
            num1[i] = A[i] - '0';
            num2[i] = B[i] - '0';
        }
        if(n == 1)
        {
            printf("Case #%d: %d\n",iCase,(num1[0]+num2[0])%10);
            continue;
        }
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i = 0;i < n;i++)
        {
            a[num1[i]] ++;
            b[num2[i]] ++;
        }
        int x = 0, y = 0;
        int ttt = -1;
        for(int i = 1;i <= 9;i++)
            for(int j = 1;j <= 9;j++)
                if(a[i] && b[j] && ((i+j)%10) > ttt )
                {
                    x = i;
                    y = j;
                    ttt = (x+y)%10;
                }
        a[x]--;
        b[y]--;
        int cnt = 0;
        ans[cnt++] = (x+y)%10;

        for(int p = 9;p >= 0;p--)
        {
            for(int i = 0;i <= 9;i++)
                if(a[i])
                {
                    if(i <= p)
                    {
                        int j = p-i;
                        int k = min(a[i],b[j]);
                        a[i] -= k;
                        b[j] -= k;
                        while(k--)
                            ans[cnt++] = p;
                    }
                    int j = 10 + p - i;
                    if(j > 9)continue;
                    int k = min(a[i],b[j]);
                    a[i] -= k;
                    b[j] -= k;
                    while(k--)
                        ans[cnt++] = p;
                }
        }
        printf("Case #%d: ",iCase);
        int s = 0;
        while(s < cnt-1 && ans[s] == 0)s++;
        for(int i = s;i < cnt;i++)
            printf("%d",ans[i]);
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值