问题 F: 是你飘了,还是我拿不动刀了
时间限制: 1 Sec 内存限制: 128 MB提交: 929 解决: 161
题目描述
Eternally给出长度在1000以内的英语文章,让你找出文章中的单词,按照英语的格式是每个单词是以空格分开的,但是呢,在这里不同,每个单词是以除大小写字母以外的字符来分开的。
例如Eternally#is#a#student中Eternally,is,a,student是单词。
(不必多想,Eternally输入的文章中的每个单词有可能在英语中不是单词)。
输入
输入包含多组输入,每行是一篇文章(文章,是没有空格的)。
输出
输出有特定的格式,输出单词时请按照单词在文章中的顺序输出单词。(如果同一个单词有多个,那么就只输出最先出现的那个),如果是Eternally开玩笑给的文章中没单词,那么输出NO.
样例输入
Eternally@is@a@student
样例输出
Case 1:
Eternally
is
a
student
提示
思路:
重点就是要考虑到A和a是一个字母,或者AABB与aabb是相同的字符串。考虑到这一点即可。
代码;
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <map>
using namespace std;
char ss[1005];
int main()
{
string s;
int cas=1,ans;
while(gets(ss))
{
ans=0;
cout<<"Case "<<cas++<<":"<<endl;
s=ss;
map<string,int>m;
string a,aa;
for(int i=0;i<strlen(ss);i++){
if(s[i]>='a'&&s[i]<='z'){
a+=s[i];
aa+=s[i];
}
else if(s[i]>='A'&&s[i]<='Z'){
a+=s[i];
aa+='a'+s[i]-'A';
}
else
{
if(m[aa]==0&&a!=""){
cout<<a<<endl;
ans=1;
}
m[aa]=1;
aa="";
a="";
}
}
if(m[aa]==0&&a!=""){
cout<<a<<endl;
ans=1;
}
if(ans==0)
cout<<"NO"<<endl;
}
}
/**************************************************************
Problem: 6027
User: 20163940
Language: C++
Result: 正确
Time:0 ms
Memory:1720 kb
****************************************************************/