POJ1068题(s括号串可有两种表示,p和w)

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24751 Accepted: 14559

Description

Let S = s1 s2…s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2…pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2…wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S       (((()()())))
P-sequence      4 5 6666
W-sequence      1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
题目意思:s串是一串括号,可有两种表示,p和w,当用p的时候,每个数记录的是当前右括号之前有多少个左括号。
当用w的时候,每个数记录的是当前右括号前与之匹配且没有和其他右括号匹配的左括号编号,当然,此编号是相对于右括号来说的。
代码如下:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define maxn 200
using namespace std;
int a[maxn];//用来模拟记录括号,也就是还原s原本的序列
int v[maxn];
int main()
{
    int t;
    int n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        memset(a,0,sizeof(a));
        memset(v,0,sizeof(v));
        int i, j;
        int x;//要输入的p序列
        int t=0;//记录当前左括号的数目
        int index=1;//记录当前括号的下标;
        for(i=0;i<n;i++)
            {
                cin>>x;//每次输入一个右括号,同时补全左边括号
                if(x>t)
                {
                    int temp=x-t;//记录当前的左边还需要填多少个左括号
                    t=x;
                    while(temp--)
                    {
                        a[index++]=0;//补右括号
                    }
                }
                a[index++]=1;//补左括号
            }
         int flag = 0;
        int num = index; // 总的括号数目
        //for(int i = 1; i < num; i++) printf("%d ", a[i]); printf("\n");
        for(int i = 1; i < num; i++) // 从前往后遍历 )
        {
            if(a[i] == 1)
            {
                flag = 0;
                int ans = 0;
                for(int j = i-1; j >= 1; j--) // 从后往前匹配,碰到一个没被访问的就匹配,输出答案,然后标志以访问,下一个则要往前遍历
                {
                    if(flag == 1) break;
                    if(a[j] == 0 && v[j] && flag == 0)
                    {
                         ans++;
                    }
                    else if(a[j] == 0 && !v[j])
                    {
                        ans++;
                        v[j] = 1;
                        printf("%d ", ans);
                        flag = 1;
                        break;
                    }
                }
            }
        }
         printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值