HDU——1048 The Hardest Problem Ever

Problem Description

Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked.
You are a sub captain of Caesar’s army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is ‘A’, the cipher text would be ‘F’). Since you are creating plain text out of Caesar’s messages, you will do the opposite:

Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.

A single data set has 3 components:

Start line - A single line, “START”

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar

End line - A single line, “END”

Following the final data set will be a single line, “ENDOFINPUT”.

Output

For each data set, there will be exactly one line of output. This is the original message by Caesar.

Sample Input

START
NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
END
START
N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
END
START
IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
END
ENDOFINPUT

Sample Output

IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

解题思路:

 看到题目是 The hardest problem ever 时,还在想一定是很难的题目吧!但是读完整个题目发现实际上是个水题,但是题目为the hardest problem ever 也是情理之中,因为–> ‘The hardest situation Caesar ever faced was keeping himself alive.’
 言归正传,本题的解决要点在于寻找 Cipher text 与 Plain text 中字符的对应关系。毋庸置疑肯定是从ASCII下手。首先观察一下是否有什么规律–Cipher text是按顺序的,Plain text 也是按顺序排列的,只是循环后移了5个单位。找到规律之后,就可以很轻松的找到前后ASCII之间的关系,问题基本上也就解决了。
 此外,写代码过程中还顺带复习了一个知识点(好久不用,有点忘记了):
 scanf 与 gets 输入字符串时的异同:
  1.不同点:
    scanf不能接受空格、制表符Tab、回车等;
   而gets能够接受空格、制表符Tab和回车等;
   2.相同点:
   字符串接受结束后自动加’\0’。

代码:

#include <stdio.h>
#include <string.h>
using namespace std;

int main(){
    char flag[11];  //用于接收结束开始符;
    char str[200];
    int t;
    gets(flag);
    while(strcmp(flag , "ENDOFINPUT") != 0){
        gets(str);
        t = strlen(str);
        int temp = 0;
        for(int i = 0 ; i < t ; i ++){
            temp = str[i];
            if(str[i] >= 65 && str[i] <= 90){
                temp = temp - 70;
                if(temp < 0)
                    temp = temp + 26 + 65;
                else
                    temp = temp + 65;
            }
            printf("%c",temp);
        }
        printf("\n");
        gets(flag);
        gets(flag);
    }
    return 0;
}
  • 2
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值