acm_step1.1.6 1.1.7 1.1.8

1.1.6和1.1.4相似,不过是少了n=0时不做处理那个条件,1.1.7和1.1.1相似,不过多了输出一个空行而已。1.1.8和1.1.5类似,下面来看看1.1.8。
题目描述:
Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output
10

15

6
题意:先在第一行输入一个数字N,表示你将处理N行的数据,接下来输入M,表示改行要处理的M个数据,然后求和,最后要求在两个输出的和之间要有一个空行。(注意:是两个输出结果之间)N行就是N个M。
上代码:

#include<stdio.h>

int main()
{
    int N, M, i, j, a;
    int sum = 0;

    while (scanf("%d", &N) != EOF)
    {
        for (i = 0; i < N; i++)
        {
            scanf("%d", &M);
            for (j = 0; j < M; j++)
            {
                scanf("%d", &a);
                sum += a;
            }
            if (i != N - 1)
                printf("%d\n\n", sum);
            else
                printf("%d\n", sum);
            sum = 0;
        }
    }

    return 0;
}

难点:输出结果后再输出空行,但是输出到最后一行时,将不再输出空行。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值