hdu2104 hide handkerchief(C语言)

这篇博客介绍了儿童游戏中的一种玩法——隐藏手帕,玩家围成一圈,Haha根据特定规则寻找手帕。问题转化为判断Haha能否遍历所有箱子。通过计算N和M的最大公约数(GCD),当GCD等于1时,Haha能找到手帕,否则不能。博客提供了C语言的AC代码实现来解决这个问题。
摘要由CSDN通过智能技术生成
Problem Description
The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".
 

Input
There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.
 

Output
For each input case, you should only the result that Haha can find the handkerchief or not.
 

Sample Input
  
  
3 2 -1 -1
 

Sample Output
  
  
YES
 

Source



C语言AC代码
#include<stdio.h>
int gcd(int a,int b)
{return (b>0)?gcd(b,a%b):a;}
int main()
{
    int k,n,m;
    while(scanf("%d%d",&n,&m),n!=-1&&m!=-1)
    {
        k=gcd(n,m);
        if(k==1) printf("YES\n");
        else printf("POOR Haha\n");
    }
    return 0;
}
思路: 1 要遍历所有的人,所以要确定是否能遍历
            2 N%M的值,只有在N和M都为质数的时候,Haha会遍历完所有的数,
3     GCD最大公约数,前面做过,又忘了,要复习!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值