程序员入门水平,贴出代码大家一起进步!
题目
本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。
输入格式:
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。
输出格式:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:
如果密码合法,输出Your password is wan mei.;
如果密码太短,不论合法与否,都输出Your password is tai duan le.;
如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.;
如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.;
如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.。
输入样例:
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6
输出样例:
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.
思路||总结
- 简单题目,代码清晰。
AC代码
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
int flag(char str[]);
int N;
scanf("%d ",&N);
char str[N][100];
int i;
for(i=0;i<N;i++)gets(str[i]);
for(i=0;i<N;i++)
switch(flag(str[i]))
{
case 1:printf("Your password is tai duan le.\n");break;
case 2:printf("Your password is tai luan le.\n");break;
case 3:printf("Your password needs shu zi.\n");break;
case 4:printf("Your password needs zi mu.\n");break;
default:printf("Your password is wan mei.\n");
};
return 0;
}
int flag(char str[])
{
int i,countup=0,countlow=0,countnum=0,countpoint=0,other=0,flag=0,l=strlen(str);
for(i=0;i<l;i++)
{
if(str[i]>='A'&&str[i]<='Z')countup++;
else if(str[i]>='a'&&str[i]<='z')countlow++;
else if(str[i]>='0'&&str[i]<='9')countnum++;
else if(str[i]=='.')countpoint++;
else other++;
};
if(l<6)flag=1;
else if(other>0)flag=2;
else if(countup+countlow>0&&countnum==0)flag=3;
else if(countnum>0&&countup+countlow==0)flag=4;
return flag;
}